# CVE-2020-10960: MediaWiki makeCollapsible allows applying event handler to any CSS selector

> Users can inject CSS classes to hide or show UI elements, bypassing intended interface restrictions, though direct XSS is not possible.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-mediawiki-2020-10960, DEBIAN-CVE-2020-10960, DSA-4651-1, GHSA-pfm2-mqwj-ggm5, MGASA-2020-0167, UBUNTU-CVE-2020-10960

## What is CVE-2020-10960?

CVE-2020-10960 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 3 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In MediaWiki before 1.34.1, users can add various Cascading Style Sheets (CSS) classes (which can affect what content is shown or hidden in the user interface) to arbitrary DOM nodes via HTML content within a MediaWiki page. This occurs because jquery.makeCollapsible allows applying an event handler to any Cascading Style Sheets (CSS) selector. There is no known way to exploit this for cross-site scripting (XSS).

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2020-10960?

7 open source packages ship an affected version, including mediawiki/core and mediawiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki/core` | Packagist | From 1.31.0 | 1.31.7 |
| `mediawiki/core` | Packagist | From 1.31.0 | 1.31.7 |
| `mediawiki/core` | Packagist | From 1.33.0 | 1.33.3 |
| `mediawiki/core` | Packagist | From 1.33.0 | 1.33.3 |
| `mediawiki/core` | Packagist | From 1.34.0 | 1.34.1 |
| `mediawiki/core` | Packagist | From 1.34.0 | 1.34.1 |
| `mediawiki` | Bitnami | All versions | 1.34.1 |

Products: Mediawiki Mediawiki.

## How do I fix CVE-2020-10960?

Upgrade mediawiki/core to a fixed version for your release line: 1.31.7, 1.33.3 or 1.34.1.

## Is CVE-2020-10960 being exploited?

There is no known exploitation of CVE-2020-10960 in the wild and no public exploit code.

## Other vulnerabilities in Mediawiki Mediawiki

- [CVE-2023-37303](https://insights.sbomify.com/CVE-2023-37303/): Denial of service in n/a (critical 9.8)
- [CVE-2022-29904](https://insights.sbomify.com/CVE-2022-29904/): SQL injection in n/a (critical 9.8)
- [CVE-2022-29906](https://insights.sbomify.com/CVE-2022-29906/): Missing authorization in n/a (critical 9.8)
- [CVE-2022-28205](https://insights.sbomify.com/CVE-2022-28205/): Business logic in n/a (critical 9.8)
- [CVE-2022-28206](https://insights.sbomify.com/CVE-2022-28206/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10960 and fix it if it is affected.

What it is: CVE-2020-10960 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 3 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-10960 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki/core (Packagist): affected from 1.31.0; fixed in 1.31.7
- mediawiki/core (Packagist): affected from 1.31.0; fixed in 1.31.7
- mediawiki/core (Packagist): affected from 1.33.0; fixed in 1.33.3
- mediawiki/core (Packagist): affected from 1.33.0; fixed in 1.33.3
- mediawiki/core (Packagist): affected from 1.34.0; fixed in 1.34.1
- mediawiki/core (Packagist): affected from 1.34.0; fixed in 1.34.1
- mediawiki (Bitnami): affected all versions; fixed in 1.34.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10960/ (Markdown: https://insights.sbomify.com/CVE-2020-10960/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10960
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10960
- OSV: https://osv.dev/vulnerability/CVE-2020-10960

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10960/
Summaries are generated and may contain mistakes; the official description above is the record.
