CVE-2020-10994 Out-of-bounds reads in Pillow

Medium 5.5 Published Updated

Attackers can cause out-of-bounds reads and potential code execution by tricking users into opening a crafted JP2 file with Pillow.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-10994?

CVE-2020-10994 is a medium-severity memory corruption vulnerability in Canonical Ubuntu Linux, published on 25 Jun 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

In libImaging/Jpeg2KDecode.c in Pillow before 7.1.0, there are multiple out-of-bounds reads via a crafted JP2 file.

Weakness: CWE-125

Which versions are affected by CVE-2020-10994?

4 open source packages ship an affected version, including pillow. It affects 3 products.

PackageAffectedFixed in
pillow BitnamiAll versions7.1.0
pillow PyPIAll versions7.0.0
pillow PyPIAll versions7.1.0
pillow PyPIAll versions7.1.0

Products include Canonical Ubuntu Linux, Fedoraproject Fedora, Python Pillow.

How do I fix CVE-2020-10994?

Upgrade pillow to a fixed version for your release line: 7.1.0 or 7.0.0.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2020-10994 being exploited?

There is no known exploitation of CVE-2020-10994 in the wild and no public exploit code.

All Canonical Ubuntu Linux vulnerabilities

Sources

Also known as BIT-pillow-2020-10994, DEBIAN-CVE-2020-10994, GHSA-vj42-xq3r-hr3r, PYSEC-2020-79, UBUNTU-CVE-2020-10994.

Is CVE-2020-10994 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free