# CVE-2020-10994: Out-of-bounds reads in Pillow

> Attackers can cause out-of-bounds reads and potential code execution by tricking users into opening a crafted JP2 file with Pillow.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-pillow-2020-10994, DEBIAN-CVE-2020-10994, GHSA-vj42-xq3r-hr3r, PYSEC-2020-79, UBUNTU-CVE-2020-10994

## What is CVE-2020-10994?

CVE-2020-10994 is a medium-severity memory corruption vulnerability in Canonical Ubuntu Linux, published on 25 Jun 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In libImaging/Jpeg2KDecode.c in Pillow before 7.1.0, there are multiple out-of-bounds reads via a crafted JP2 file.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2020-10994?

4 open source packages ship an affected version, including pillow. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | Bitnami | All versions | 7.1.0 |
| `pillow` | PyPI | All versions | 7.0.0 |
| `pillow` | PyPI | All versions | 7.1.0 |
| `pillow` | PyPI | All versions | 7.1.0 |

Products: Canonical Ubuntu Linux, Fedoraproject Fedora, Python Pillow.

## How do I fix CVE-2020-10994?

Upgrade pillow to a fixed version for your release line: 7.1.0 or 7.0.0.

## Is CVE-2020-10994 being exploited?

There is no known exploitation of CVE-2020-10994 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10994 and fix it if it is affected.

What it is: CVE-2020-10994 is a medium-severity memory corruption vulnerability in Canonical Ubuntu Linux, published on 25 Jun 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-10994 in the wild and no public exploit code.

Affected packages and fixed versions:
- pillow (Bitnami): affected all versions; fixed in 7.1.0
- pillow (PyPI): affected all versions; fixed in 7.0.0
- pillow (PyPI): affected all versions; fixed in 7.1.0
- pillow (PyPI): affected all versions; fixed in 7.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10994/ (Markdown: https://insights.sbomify.com/CVE-2020-10994/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10994
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10994
- OSV: https://osv.dev/vulnerability/CVE-2020-10994

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10994/
Summaries are generated and may contain mistakes; the official description above is the record.
