# CVE-2020-10997: Information disclosure in n/a

> Percona XtraBackup leaks sensitive command-line arguments in backup files and history tables, exposing runtime secrets to attackers.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-percona-xtrabackup-2020-10997, BIT-percona-xtrabackup-binary-2020-10997, GHSA-p7x7-rwp6-7mfx

## What is CVE-2020-10997?

CVE-2020-10997 is a medium-severity vulnerability in n/a, published on 27 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Percona XtraBackup before 2.4.20 unintentionally writes the command line to any resulting backup file output. This may include sensitive arguments passed at run time. In addition, when --history is passed at run time, this command line is also written to the PERCONA_SCHEMA.xtrabackup_history table.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2020-10997?

2 open source packages ship an affected version, including percona-xtrabackup and percona-xtrabackup-binary. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `percona-xtrabackup` | Bitnami | From 2.4.11 | 2.4.20, 8.0.11 |
| `percona-xtrabackup-binary` | Bitnami | From 2.4.11 | 2.4.20, 8.0.11 |

Products: Percona Xtrabackup.

## How do I fix CVE-2020-10997?

Upgrade percona-xtrabackup to a fixed version for your release line: 2.4.20 or 8.0.11.

## Is CVE-2020-10997 being exploited?

There is no known exploitation of CVE-2020-10997 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-25834](https://insights.sbomify.com/CVE-2022-25834/): Command injection in n/a (high 7.8)
- [CVE-2022-26944](https://insights.sbomify.com/CVE-2022-26944/): Information disclosure in n/a (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-10997 and fix it if it is affected.

What it is: CVE-2020-10997 is a medium-severity vulnerability in n/a, published on 27 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-10997 in the wild and no public exploit code.

Affected packages and fixed versions:
- percona-xtrabackup (Bitnami): affected from 2.4.11; fixed in 2.4.20, 8.0.11
- percona-xtrabackup-binary (Bitnami): affected from 2.4.11; fixed in 2.4.20, 8.0.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-10997/ (Markdown: https://insights.sbomify.com/CVE-2020-10997/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-10997
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-10997
- OSV: https://osv.dev/vulnerability/CVE-2020-10997

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-10997/
Summaries are generated and may contain mistakes; the official description above is the record.
