CVE-2020-11001 Possible XSS attack in Wagtail

Medium 5.8 Published Updated

A cross-site scripting vulnerability in Wagtail allows limited editors to execute actions with higher-privileged users' credentials via crafted page revisions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-11001?

CVE-2020-11001 is a medium-severity cross-site scripting vulnerability in wagtail, published on 14 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

In Wagtail before versions 2.8.1 and 2.7.2, a cross-site scripting (XSS) vulnerability exists on the page revision comparison view within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could potentially craft a page revision history that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin.

Patched versions have been released as Wagtail 2.7.2 (for the LTS 2.7 branch) and Wagtail 2.8.1 (for the current 2.8 branch).

Weakness: CWE-80, CWE-79

Which versions are affected by CVE-2020-11001?

5 open source packages ship an affected version, including wagtail. It affects 1 product.

PackageAffectedFixed in
wagtail PyPIFrom 1.92.7.2
wagtail PyPIFrom 1.9.02.7.2
wagtail PyPIFrom 1.9.02.7.2
wagtail PyPIFrom 2.8.02.8.1
wagtail PyPIFrom 2.8.02.8.1

Products include Torchbox Wagtail.

How do I fix CVE-2020-11001?

Upgrade wagtail to a fixed version for your release line: 2.7.2 or 2.8.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-11001 being exploited?

There is no known exploitation of CVE-2020-11001 in the wild and no public exploit code.

Sources

Also known as GHSA-v2wc-pfq2-5cm6, PYSEC-2020-152.

Is CVE-2020-11001 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free