{"answers":{"affected":"5 open source packages ship an affected version, including wagtail. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-11001 in the wild and no public exploit code.","fix":"Upgrade wagtail to a fixed version for your release line: 2.7.2 or 2.8.1.","what":"CVE-2020-11001 is a medium-severity cross-site scripting vulnerability in wagtail, published on 14 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-11001 and fix it if it is affected.\n\nWhat it is: CVE-2020-11001 is a medium-severity cross-site scripting vulnerability in wagtail, published on 14 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-11001 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wagtail (PyPI): affected from 1.9; fixed in 2.7.2\n- wagtail (PyPI): affected from 1.9.0; fixed in 2.7.2\n- wagtail (PyPI): affected from 1.9.0; fixed in 2.7.2\n- wagtail (PyPI): affected from 2.8.0; fixed in 2.8.1\n- wagtail (PyPI): affected from 2.8.0; fixed in 2.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-11001/ (Markdown: https://insights.sbomify.com/CVE-2020-11001/index.md)","id":"CVE-2020-11001","markdown":"https://insights.sbomify.com/CVE-2020-11001/index.md","name":"CVE-2020-11001","record":{"aliases":["GHSA-v2wc-pfq2-5cm6","PYSEC-2020-152"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Wagtail CMS","requires_auth":"low_privilege","summary":"A cross-site scripting vulnerability in Wagtail allows limited editors to execute actions with higher-privileged users' credentials via crafted page revisions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"wagtail","vendor":"torchbox"}],"cvss":{"score":5.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In Wagtail before versions 2.8.1 and 2.7.2, a cross-site scripting (XSS) vulnerability exists on the page revision\ncomparison view within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail\nadmin could potentially craft a page revision history that, when viewed by a user with higher privileges, could perform\nactions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to\nthe Wagtail admin.\n\nPatched versions have been released as Wagtail 2.7.2 (for the LTS 2.7 branch) and Wagtail 2.8.1 (for the current 2.8 branch).","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Possible XSS attack in Wagtail","id":"CVE-2020-11001","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":5,"n_references":1,"next":{"headline":"Remote Code Execution (RCE) vulnerability in dropwizard-validation","id":"CVE-2020-11002"},"packages":[{"ecosystem":"PyPI","fixed":["2.7.2"],"introduced":["1.9"],"last_affected":[],"package":"wagtail","purl":"pkg:pypi/wagtail","source":"PYSEC-2020-152"},{"ecosystem":"PyPI","fixed":["2.7.2"],"introduced":["1.9.0"],"last_affected":[],"package":"wagtail","purl":null,"source":"GHSA-v2wc-pfq2-5cm6"},{"ecosystem":"PyPI","fixed":["2.7.2"],"introduced":["1.9.0"],"last_affected":[],"package":"wagtail","purl":"pkg:pypi/wagtail","source":"GHSA-v2wc-pfq2-5cm6"},{"ecosystem":"PyPI","fixed":["2.8.1"],"introduced":["2.8.0"],"last_affected":[],"package":"wagtail","purl":null,"source":"GHSA-v2wc-pfq2-5cm6"},{"ecosystem":"PyPI","fixed":["2.8.1"],"introduced":["2.8.0"],"last_affected":[],"package":"wagtail","purl":"pkg:pypi/wagtail","source":"GHSA-v2wc-pfq2-5cm6"}],"prev":{"headline":"Improper URL validation in GreenBrowser","id":"CVE-2020-11000"},"products":["wagtail"],"published":"2020-04-14","related":[{"cvss_score":7.3,"headline":"Wagtail: Reflected XSS in dynamic image URL generator view","id":"CVE-2026-54263","kev_date_added":null,"published":"2026-07-01"},{"cvss_score":6.5,"headline":"Wagtail: Improper permission handling in image preview","id":"CVE-2026-54261","kev_date_added":null,"published":"2026-07-01"},{"cvss_score":6.5,"headline":"Wagtail: Improper permission handling when comparing revisions","id":"CVE-2026-44197","kev_date_added":null,"published":"2026-05-11"},{"cvss_score":6.5,"headline":"Wagtail: Improper permission handling when deleting form submissions","id":"CVE-2026-44199","kev_date_added":null,"published":"2026-05-11"},{"cvss_score":6.5,"headline":"Wagtail: Improper permission handling when copying pages","id":"CVE-2026-44200","kev_date_added":null,"published":"2026-05-11"},{"cvss_score":6.5,"headline":"Wagtail regular expression denial-of-service via search query parsing","id":"CVE-2024-39317","kev_date_added":null,"published":"2024-07-11"},{"cvss_score":6.4,"headline":"Wagtail vulnerable to stored Cross-site Scripting attack via ModelAdmin views","id":"CVE-2023-28836","kev_date_added":null,"published":"2023-04-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-11-19","vendors":["wagtail"]},"summary":"A cross-site scripting vulnerability in Wagtail allows limited editors to execute actions with higher-privileged users' credentials via crafted page revisions.","url":"https://insights.sbomify.com/CVE-2020-11001/"}