# CVE-2020-11001: Possible XSS attack in Wagtail

> A cross-site scripting vulnerability in Wagtail allows limited editors to execute actions with higher-privileged users' credentials via crafted page revisions.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Apr 2020
- **Updated:** 19 Nov 2024
- **Also known as:** GHSA-v2wc-pfq2-5cm6, PYSEC-2020-152

## What is CVE-2020-11001?

CVE-2020-11001 is a medium-severity cross-site scripting vulnerability in wagtail, published on 14 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In Wagtail before versions 2.8.1 and 2.7.2, a cross-site scripting (XSS) vulnerability exists on the page revision
comparison view within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail
admin could potentially craft a page revision history that, when viewed by a user with higher privileges, could perform
actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to
the Wagtail admin.

Patched versions have been released as Wagtail 2.7.2 (for the LTS 2.7 branch) and Wagtail 2.8.1 (for the current 2.8 branch).

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-11001?

5 open source packages ship an affected version, including wagtail. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wagtail` | PyPI | From 1.9 | 2.7.2 |
| `wagtail` | PyPI | From 1.9.0 | 2.7.2 |
| `wagtail` | PyPI | From 1.9.0 | 2.7.2 |
| `wagtail` | PyPI | From 2.8.0 | 2.8.1 |
| `wagtail` | PyPI | From 2.8.0 | 2.8.1 |

Products: Torchbox Wagtail.

## How do I fix CVE-2020-11001?

Upgrade wagtail to a fixed version for your release line: 2.7.2 or 2.8.1.

## Is CVE-2020-11001 being exploited?

There is no known exploitation of CVE-2020-11001 in the wild and no public exploit code.

## Other vulnerabilities in wagtail

- [CVE-2026-54263](https://insights.sbomify.com/CVE-2026-54263/): Wagtail: Reflected XSS in dynamic image URL generator view (high 7.3)
- [CVE-2026-54261](https://insights.sbomify.com/CVE-2026-54261/): Wagtail: Improper permission handling in image preview (medium 6.5)
- [CVE-2026-44197](https://insights.sbomify.com/CVE-2026-44197/): Wagtail: Improper permission handling when comparing revisions (medium 6.5)
- [CVE-2026-44199](https://insights.sbomify.com/CVE-2026-44199/): Wagtail: Improper permission handling when deleting form submissions (medium 6.5)
- [CVE-2026-44200](https://insights.sbomify.com/CVE-2026-44200/): Wagtail: Improper permission handling when copying pages (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11001 and fix it if it is affected.

What it is: CVE-2020-11001 is a medium-severity cross-site scripting vulnerability in wagtail, published on 14 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-11001 in the wild and no public exploit code.

Affected packages and fixed versions:
- wagtail (PyPI): affected from 1.9; fixed in 2.7.2
- wagtail (PyPI): affected from 1.9.0; fixed in 2.7.2
- wagtail (PyPI): affected from 1.9.0; fixed in 2.7.2
- wagtail (PyPI): affected from 2.8.0; fixed in 2.8.1
- wagtail (PyPI): affected from 2.8.0; fixed in 2.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11001/ (Markdown: https://insights.sbomify.com/CVE-2020-11001/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11001
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11001
- OSV: https://osv.dev/vulnerability/CVE-2020-11001

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11001/
Summaries are generated and may contain mistakes; the official description above is the record.
