{"answers":{"affected":"4 open source packages ship an affected version, including io.dropwizard:dropwizard-validation. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-11002 in the wild and no public exploit code.","fix":"Upgrade io.dropwizard:dropwizard-validation to a fixed version for your release line: 1.3.21 or 2.0.3.","what":"CVE-2020-11002 is a high-severity code injection vulnerability in dropwizard, published on 10 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-11002 and fix it if it is affected.\n\nWhat it is: CVE-2020-11002 is a high-severity code injection vulnerability in dropwizard, published on 10 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-11002 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.dropwizard:dropwizard-validation (Maven): affected all versions; fixed in 1.3.21\n- io.dropwizard:dropwizard-validation (Maven): affected all versions; fixed in 1.3.21\n- io.dropwizard:dropwizard-validation (Maven): affected from 2.0.0; fixed in 2.0.3\n- io.dropwizard:dropwizard-validation (Maven): affected from 2.0.0; fixed in 2.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-11002/ (Markdown: https://insights.sbomify.com/CVE-2020-11002/index.md)","id":"CVE-2020-11002","markdown":"https://insights.sbomify.com/CVE-2020-11002/index.md","name":"CVE-2020-11002","record":{"aliases":["GHSA-8jpx-m2wh-2v34"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Java validation library","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code via Java EL injection in self-validating beans, requiring an upgrade to the Dropwizard validation library.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"dropwizard_validation","vendor":"dropwizard"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"dropwizard-validation before versions 2.0.3 and 1.3.21 has a remote code execution vulnerability. A server-side template injection was identified in the self-validating feature enabling attackers to inject arbitrary Java EL expressions, leading to Remote Code Execution (RCE) vulnerability. If you are using a self-validating bean an upgrade to Dropwizard 1.3.21/2.0.3 or later is strongly recommended. The changes introduced in Dropwizard 1.3.19 and 2.0.2 for CVE-2020-5245 unfortunately did not fix the underlying issue completely. The issue has been fixed in dropwizard-validation 1.3.21 and 2.0.3 or later. We strongly recommend upgrading to one of these versions.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Remote Code Execution (RCE) vulnerability in dropwizard-validation","id":"CVE-2020-11002","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2020"},"n_packages":4,"n_references":7,"next":{"headline":"CSRF and DNS Rebinding in Oasis","id":"CVE-2020-11003"},"packages":[{"ecosystem":"Maven","fixed":["1.3.21"],"introduced":["0"],"last_affected":[],"package":"io.dropwizard:dropwizard-validation","purl":null,"source":"GHSA-8jpx-m2wh-2v34"},{"ecosystem":"Maven","fixed":["1.3.21"],"introduced":["0"],"last_affected":[],"package":"io.dropwizard:dropwizard-validation","purl":"pkg:maven/io.dropwizard/dropwizard-validation","source":"GHSA-8jpx-m2wh-2v34"},{"ecosystem":"Maven","fixed":["2.0.3"],"introduced":["2.0.0"],"last_affected":[],"package":"io.dropwizard:dropwizard-validation","purl":null,"source":"GHSA-8jpx-m2wh-2v34"},{"ecosystem":"Maven","fixed":["2.0.3"],"introduced":["2.0.0"],"last_affected":[],"package":"io.dropwizard:dropwizard-validation","purl":"pkg:maven/io.dropwizard/dropwizard-validation","source":"GHSA-8jpx-m2wh-2v34"}],"prev":{"headline":"Possible XSS attack in Wagtail","id":"CVE-2020-11001"},"products":["dropwizard"],"published":"2020-04-10","related":[{"cvss_score":7.9,"headline":"Remote Code Execution (RCE) vulnerability in dropwizard-validation","id":"CVE-2020-5245","kev_date_added":null,"published":"2020-02-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["dropwizard"]},"summary":"Attackers can execute arbitrary code via Java EL injection in self-validating beans, requiring an upgrade to the Dropwizard validation library.","url":"https://insights.sbomify.com/CVE-2020-11002/"}