# CVE-2020-11002: Remote Code Execution (RCE) vulnerability in dropwizard-validation

> Attackers can execute arbitrary code via Java EL injection in self-validating beans, requiring an upgrade to the Dropwizard validation library.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-8jpx-m2wh-2v34

## What is CVE-2020-11002?

CVE-2020-11002 is a high-severity code injection vulnerability in dropwizard, published on 10 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

dropwizard-validation before versions 2.0.3 and 1.3.21 has a remote code execution vulnerability. A server-side template injection was identified in the self-validating feature enabling attackers to inject arbitrary Java EL expressions, leading to Remote Code Execution (RCE) vulnerability. If you are using a self-validating bean an upgrade to Dropwizard 1.3.21/2.0.3 or later is strongly recommended. The changes introduced in Dropwizard 1.3.19 and 2.0.2 for CVE-2020-5245 unfortunately did not fix the underlying issue completely. The issue has been fixed in dropwizard-validation 1.3.21 and 2.0.3 or later. We strongly recommend upgrading to one of these versions.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2020-11002?

4 open source packages ship an affected version, including io.dropwizard:dropwizard-validation. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.dropwizard:dropwizard-validation` | Maven | All versions | 1.3.21 |
| `io.dropwizard:dropwizard-validation` | Maven | All versions | 1.3.21 |
| `io.dropwizard:dropwizard-validation` | Maven | From 2.0.0 | 2.0.3 |
| `io.dropwizard:dropwizard-validation` | Maven | From 2.0.0 | 2.0.3 |

Products: Dropwizard Dropwizard Validation.

## How do I fix CVE-2020-11002?

Upgrade io.dropwizard:dropwizard-validation to a fixed version for your release line: 1.3.21 or 2.0.3.

## Is CVE-2020-11002 being exploited?

There is no known exploitation of CVE-2020-11002 in the wild and no public exploit code.

## Other vulnerabilities in dropwizard

- [CVE-2020-5245](https://insights.sbomify.com/CVE-2020-5245/): Remote Code Execution (RCE) vulnerability in dropwizard-validation (high 7.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11002 and fix it if it is affected.

What it is: CVE-2020-11002 is a high-severity code injection vulnerability in dropwizard, published on 10 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-11002 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.dropwizard:dropwizard-validation (Maven): affected all versions; fixed in 1.3.21
- io.dropwizard:dropwizard-validation (Maven): affected all versions; fixed in 1.3.21
- io.dropwizard:dropwizard-validation (Maven): affected from 2.0.0; fixed in 2.0.3
- io.dropwizard:dropwizard-validation (Maven): affected from 2.0.0; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11002/ (Markdown: https://insights.sbomify.com/CVE-2020-11002/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11002
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11002
- OSV: https://osv.dev/vulnerability/CVE-2020-11002

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11002/
Summaries are generated and may contain mistakes; the official description above is the record.
