# CVE-2020-11006: Potential remote code execution in Shopizer

> Attackers can inject scripts into Shopizer forms that execute upon data retrieval, potentially leading to remote code execution.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-8pc4-gvfw-634p

## What is CVE-2020-11006?

CVE-2020-11006 is a critical cross-site scripting vulnerability in shopizer-ecommerce shopizer, published on 8 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Shopizer before version 2.11.0, a script can be injected in various forms and saved in the database, then executed when information is fetched from backend. This has been patched in version 2.11.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-11006?

It affects 1 product.


Products: Shopizer Shopizer.

## How do I fix CVE-2020-11006?

No fix has been published for CVE-2020-11006 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-11006 being exploited?

There is no known exploitation of CVE-2020-11006 in the wild and no public exploit code.

## Other vulnerabilities in shopizer-ecommerce shopizer

- [CVE-2022-23063](https://insights.sbomify.com/CVE-2022-23063/): Shopizer - Insufficient Session Expiration (high 8.8)
- [CVE-2025-51605](https://insights.sbomify.com/CVE-2025-51605/): Security feature bypass in n/a (high 8.1)
- [CVE-2014-4963](https://insights.sbomify.com/CVE-2014-4963/): Missing authorization in n/a (medium 6.8)
- [CVE-2014-4964](https://insights.sbomify.com/CVE-2014-4964/): Cross-site request forgery in n/a (medium 6.8)
- [CVE-2022-23061](https://insights.sbomify.com/CVE-2022-23061/): Shopizer - IDOR delete superadmin (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11006 and fix it if it is affected.

What it is: CVE-2020-11006 is a critical cross-site scripting vulnerability in shopizer-ecommerce shopizer, published on 8 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-11006 in the wild and no public exploit code.

Affected product: shopizer-ecommerce shopizer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11006/ (Markdown: https://insights.sbomify.com/CVE-2020-11006/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11006
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11006
- OSV: https://osv.dev/vulnerability/CVE-2020-11006

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11006/
Summaries are generated and may contain mistakes; the official description above is the record.
