# CVE-2020-11010: SQL injection in Tortoise ORM

> SQL injection in Tortoise ORM allows attackers to manipulate database queries, potentially reading or modifying data.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-9j2c-x8qm-qmjq, PYSEC-2020-144

## What is CVE-2020-11010?

CVE-2020-11010 is a medium-severity SQL injection vulnerability in tortoise-orm, published on 20 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Tortoise ORM before versions 0.15.23 and 0.16.6, various forms of SQL injection have been found for MySQL and when filtering or doing mass-updates on char/text fields. SQLite & PostgreSQL are only affected when filtering with contains, starts_with, or ends_with filters (and their case-insensitive counterparts).

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2020-11010?

5 open source packages ship an affected version, including tortoise-orm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tortoise-orm` | PyPI | All versions | 0.15.23, 0.16.6 |
| `tortoise-orm` | PyPI | All versions | 0.15.23 |
| `tortoise-orm` | PyPI | All versions | 0.15.23 |
| `tortoise-orm` | PyPI | From 0.16.0 | 0.16.6 |
| `tortoise-orm` | PyPI | From 0.16.0 | 0.16.6 |

Products: Tortoise Orm Project Tortoise Orm.

## How do I fix CVE-2020-11010?

Upgrade tortoise-orm to a fixed version for your release line: 0.15.23 or 0.16.6.

## Is CVE-2020-11010 being exploited?

There is no known exploitation of CVE-2020-11010 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11010 and fix it if it is affected.

What it is: CVE-2020-11010 is a medium-severity SQL injection vulnerability in tortoise-orm, published on 20 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-11010 in the wild and no public exploit code.

Affected packages and fixed versions:
- tortoise-orm (PyPI): affected all versions; fixed in 0.15.23, 0.16.6
- tortoise-orm (PyPI): affected all versions; fixed in 0.15.23
- tortoise-orm (PyPI): affected all versions; fixed in 0.15.23
- tortoise-orm (PyPI): affected from 0.16.0; fixed in 0.16.6
- tortoise-orm (PyPI): affected from 0.16.0; fixed in 0.16.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11010/ (Markdown: https://insights.sbomify.com/CVE-2020-11010/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11010
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11010
- OSV: https://osv.dev/vulnerability/CVE-2020-11010

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11010/
Summaries are generated and may contain mistakes; the official description above is the record.
