# CVE-2020-11013: lookup Function Information Discolosure in Helm

> A malicious Helm chart can leak cluster information via the lookup function during template rendering, bypassing the expected offline behavior.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-helm-2020-11013, GHSA-q8q8-93cv-v6h8, UBUNTU-CVE-2020-11013

## What is CVE-2020-11013?

CVE-2020-11013 is a high-severity vulnerability in Helm, published on 24 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Their is an information disclosure vulnerability in Helm from version 3.1.0 and before version 3.2.0. `lookup` is a Helm template function introduced in Helm v3. It is able to lookup resources in the cluster to check for the existence of specific resources and get details about them. This can be used as part of the process to render templates. The documented behavior of `helm template` states that it does not attach to a remote cluster. However, a the recently added `lookup` template function circumvents this restriction and connects to the cluster even during `helm template` and `helm install|update|delete|rollback --dry-run`. The user is not notified of this behavior. Running `helm template` should not make calls to a cluster. This is different from `install`, which is presumed to have access to a cluster in order to load resources into Kubernetes. Helm 2 is unaffected by this vulnerability. A malicious chart author could inject a `lookup` into a chart that, when rendered through `helm template`, performs unannounced lookups against the cluster a user&#39;s `KUBECONFIG` file points to. This information can then be disclosed via the output of `helm template`. This issue has been fixed in Helm 3.2.0

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2020-11013?

3 open source packages ship an affected version, including helm.sh/helm/v3 and helm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `helm.sh/helm/v3` | Go | From 3.0.0 | 3.1.3 |
| `helm.sh/helm/v3` | Go | From 3.0.0 | 3.1.3 |
| `helm` | Bitnami | From 3.1.0 | 3.2.0 |

Products: Helm Helm.

## How do I fix CVE-2020-11013?

Upgrade helm.sh/helm/v3 to 3.1.3 or later.

## Is CVE-2020-11013 being exploited?

There is no known exploitation of CVE-2020-11013 in the wild and no public exploit code.

## Other vulnerabilities in Helm

- [CVE-2019-18658](https://insights.sbomify.com/CVE-2019-18658/): Helm Unsafe Link Following (critical 9.8)
- [CVE-2019-1010275](https://insights.sbomify.com/CVE-2019-1010275/): Helm Improper Certificate Validation (critical 9.8)
- [CVE-2019-25210](https://insights.sbomify.com/CVE-2019-25210/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-53547](https://insights.sbomify.com/CVE-2025-53547/): Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution (high 8.5)
- [CVE-2026-35204](https://insights.sbomify.com/CVE-2026-35204/): Helm has a path traversal in plugin metadata version enables arbitrary file write outside Helm plugin directory (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11013 and fix it if it is affected.

What it is: CVE-2020-11013 is a high-severity vulnerability in Helm, published on 24 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-11013 in the wild and no public exploit code.

Affected packages and fixed versions:
- helm.sh/helm/v3 (Go): affected from 3.0.0; fixed in 3.1.3
- helm.sh/helm/v3 (Go): affected from 3.0.0; fixed in 3.1.3
- helm (Bitnami): affected from 3.1.0; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11013/ (Markdown: https://insights.sbomify.com/CVE-2020-11013/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11013
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11013
- OSV: https://osv.dev/vulnerability/CVE-2020-11013

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11013/
Summaries are generated and may contain mistakes; the official description above is the record.
