# CVE-2020-11014: BIP LI01 output reordering may cause malformed SLP MINT transactions in Electron-Cash-SLP

> A logic flaw in the Mint Tool may send minting authority to the wrong address, allowing attackers to issue or destroy tokens.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 28 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-cchm-grx2-g873

## What is CVE-2020-11014?

CVE-2020-11014 is a medium-severity vulnerability in simpleledger Electron-Cash-SLP, published on 28 Apr 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Electron-Cash-SLP before version 3.6.2 has a vulnerability. All token creators that use the "Mint Tool" feature of the Electron Cash SLP Edition are at risk of sending the minting authority baton to the wrong SLP address. Sending the mint baton to the wrong address will give another party the ability to issue new tokens or permanently destroy future minting capability. This is fixed version 3.6.2.

## Which versions are affected by CVE-2020-11014?

It affects 1 product.


Products: Simpleledger Electron-Cash-Slp.

## How do I fix CVE-2020-11014?

No fix has been published for CVE-2020-11014 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-11014 being exploited?

There is no known exploitation of CVE-2020-11014 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11014 and fix it if it is affected.

What it is: CVE-2020-11014 is a medium-severity vulnerability in simpleledger Electron-Cash-SLP, published on 28 Apr 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-11014 in the wild and no public exploit code.

Affected product: simpleledger Electron-Cash-SLP. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11014/ (Markdown: https://insights.sbomify.com/CVE-2020-11014/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11014
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11014
- OSV: https://osv.dev/vulnerability/CVE-2020-11014

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11014/
Summaries are generated and may contain mistakes; the official description above is the record.
