CVE-2020-11018 Out of bound read in cliprdr_server_receive_capabilities in FreeRDP

Medium 6.5 Published Updated

A malicious client can trigger out-of-bounds reads in FreeRDP, causing resource exhaustion and denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-11018?

CVE-2020-11018 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 29 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In FreeRDP less than or equal to 2.0.0, a possible resource exhaustion vulnerability can be performed. Malicious clients could trigger out of bound reads causing memory allocation with random size. This has been fixed in 2.1.0.

Weakness: CWE-125

Which versions are affected by CVE-2020-11018?

It affects 3 products.

Products include Debian Debian Linux, Freerdp Freerdp, Opensuse Leap.

How do I fix CVE-2020-11018?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2020-11018 being exploited?

There is no known exploitation of CVE-2020-11018 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as DEBIAN-CVE-2020-11018, GHSA-8cvc-vcw7-6mfw, UBUNTU-CVE-2020-11018.

Is CVE-2020-11018 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free