CVE-2020-11020 Authentication and extension bypass in Faye

High 8.5 Published Updated

Attackers can bypass server-side extension authentication checks in Faye by appending extra segments to message channels.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-11020?

CVE-2020-11020 is a high-severity authentication bypass vulnerability in Faye, published on 29 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Faye (NPM, RubyGem) versions greater than 0.5.0 and before 1.0.4, 1.1.3 and 1.2.5, has the potential for authentication bypass in the extension system. The vulnerability allows any client to bypass checks put in place by server-side extensions, by appending extra segments to the message channel. It is patched in versions 1.0.4, 1.1.3 and 1.2.5.

Weakness: CWE-287

Which versions are affected by CVE-2020-11020?

6 open source packages ship an affected version, including faye. It affects 1 product.

PackageAffectedFixed in
faye RubyGemsFrom 0.5.01.0.4
faye RubyGemsFrom 0.5.01.0.4
faye RubyGemsFrom 1.1.01.1.3
faye RubyGemsFrom 1.1.01.1.3
faye RubyGemsFrom 1.2.01.2.5
faye RubyGemsFrom 1.2.01.2.5

Products include Faye Project Faye.

How do I fix CVE-2020-11020?

Upgrade faye to a fixed version for your release line: 1.0.4, 1.1.3 or 1.2.5.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2020-11020 being exploited?

There is no known exploitation of CVE-2020-11020 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2020-11020, GHSA-qpg4-4w7w-2mq5, UBUNTU-CVE-2020-11020.

Is CVE-2020-11020 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free