{"answers":{"affected":"6 open source packages ship an affected version, including faye. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-11020 in the wild and no public exploit code.","fix":"Upgrade faye to a fixed version for your release line: 1.0.4, 1.1.3 or 1.2.5.","what":"CVE-2020-11020 is a high-severity authentication bypass vulnerability in Faye, published on 29 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-11020 and fix it if it is affected.\n\nWhat it is: CVE-2020-11020 is a high-severity authentication bypass vulnerability in Faye, published on 29 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-11020 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- faye (RubyGems): affected from 0.5.0; fixed in 1.0.4\n- faye (RubyGems): affected from 0.5.0; fixed in 1.0.4\n- faye (RubyGems): affected from 1.1.0; fixed in 1.1.3\n- faye (RubyGems): affected from 1.1.0; fixed in 1.1.3\n- faye (RubyGems): affected from 1.2.0; fixed in 1.2.5\n- faye (RubyGems): affected from 1.2.0; fixed in 1.2.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-11020/ (Markdown: https://insights.sbomify.com/CVE-2020-11020/index.md)","id":"CVE-2020-11020","markdown":"https://insights.sbomify.com/CVE-2020-11020/index.md","name":"CVE-2020-11020","record":{"aliases":["DEBIAN-CVE-2020-11020","GHSA-qpg4-4w7w-2mq5","UBUNTU-CVE-2020-11020"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Faye messaging library","requires_auth":"low_privilege","summary":"Attackers can bypass server-side extension authentication checks in Faye by appending extra segments to message channels.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"faye","vendor":"faye_project"}],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Faye (NPM, RubyGem) versions greater than 0.5.0 and before 1.0.4, 1.1.3 and 1.2.5, has the potential for authentication bypass in the extension system. The vulnerability allows any client to bypass checks put in place by server-side extensions, by appending extra segments to the message channel. It is patched in versions 1.0.4, 1.1.3 and 1.2.5.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Authentication and extension bypass in Faye","id":"CVE-2020-11020","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"auth_bypass","year":"2020"},"n_packages":6,"n_references":2,"next":{"headline":"HTTP request which redirect to another hostname do not strip authorization header in Actions Http-Client","id":"CVE-2020-11021"},"packages":[{"ecosystem":"RubyGems","fixed":["1.0.4"],"introduced":["0.5.0"],"last_affected":[],"package":"faye","purl":null,"source":"GHSA-qpg4-4w7w-2mq5"},{"ecosystem":"RubyGems","fixed":["1.0.4"],"introduced":["0.5.0"],"last_affected":[],"package":"faye","purl":"pkg:gem/faye","source":"GHSA-qpg4-4w7w-2mq5"},{"ecosystem":"RubyGems","fixed":["1.1.3"],"introduced":["1.1.0"],"last_affected":[],"package":"faye","purl":null,"source":"GHSA-qpg4-4w7w-2mq5"},{"ecosystem":"RubyGems","fixed":["1.1.3"],"introduced":["1.1.0"],"last_affected":[],"package":"faye","purl":"pkg:gem/faye","source":"GHSA-qpg4-4w7w-2mq5"},{"ecosystem":"RubyGems","fixed":["1.2.5"],"introduced":["1.2.0"],"last_affected":[],"package":"faye","purl":null,"source":"GHSA-qpg4-4w7w-2mq5"},{"ecosystem":"RubyGems","fixed":["1.2.5"],"introduced":["1.2.0"],"last_affected":[],"package":"faye","purl":"pkg:gem/faye","source":"GHSA-qpg4-4w7w-2mq5"}],"prev":{"headline":"Out of bound read in update_recv in FreeRDP","id":"CVE-2020-11019"},"products":["Faye"],"published":"2020-04-29","related":[{"cvss_score":8,"headline":"Missing TLS certificate verification in Faye","id":"CVE-2020-15134","kev_date_added":null,"published":"2020-07-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["faye"]},"summary":"Attackers can bypass server-side extension authentication checks in Faye by appending extra segments to message channels.","url":"https://insights.sbomify.com/CVE-2020-11020/"}