# CVE-2020-11020: Authentication and extension bypass in Faye

> Attackers can bypass server-side extension authentication checks in Faye by appending extra segments to message channels.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-11020, GHSA-qpg4-4w7w-2mq5, UBUNTU-CVE-2020-11020

## What is CVE-2020-11020?

CVE-2020-11020 is a high-severity authentication bypass vulnerability in Faye, published on 29 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Faye (NPM, RubyGem) versions greater than 0.5.0 and before 1.0.4, 1.1.3 and 1.2.5, has the potential for authentication bypass in the extension system. The vulnerability allows any client to bypass checks put in place by server-side extensions, by appending extra segments to the message channel. It is patched in versions 1.0.4, 1.1.3 and 1.2.5.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2020-11020?

6 open source packages ship an affected version, including faye. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `faye` | RubyGems | From 0.5.0 | 1.0.4 |
| `faye` | RubyGems | From 0.5.0 | 1.0.4 |
| `faye` | RubyGems | From 1.1.0 | 1.1.3 |
| `faye` | RubyGems | From 1.1.0 | 1.1.3 |
| `faye` | RubyGems | From 1.2.0 | 1.2.5 |
| `faye` | RubyGems | From 1.2.0 | 1.2.5 |

Products: Faye Project Faye.

## How do I fix CVE-2020-11020?

Upgrade faye to a fixed version for your release line: 1.0.4, 1.1.3 or 1.2.5.

## Is CVE-2020-11020 being exploited?

There is no known exploitation of CVE-2020-11020 in the wild and no public exploit code.

## Other vulnerabilities in Faye

- [CVE-2020-15134](https://insights.sbomify.com/CVE-2020-15134/): Missing TLS certificate verification in Faye (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11020 and fix it if it is affected.

What it is: CVE-2020-11020 is a high-severity authentication bypass vulnerability in Faye, published on 29 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-11020 in the wild and no public exploit code.

Affected packages and fixed versions:
- faye (RubyGems): affected from 0.5.0; fixed in 1.0.4
- faye (RubyGems): affected from 0.5.0; fixed in 1.0.4
- faye (RubyGems): affected from 1.1.0; fixed in 1.1.3
- faye (RubyGems): affected from 1.1.0; fixed in 1.1.3
- faye (RubyGems): affected from 1.2.0; fixed in 1.2.5
- faye (RubyGems): affected from 1.2.0; fixed in 1.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11020/ (Markdown: https://insights.sbomify.com/CVE-2020-11020/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11020
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11020
- OSV: https://osv.dev/vulnerability/CVE-2020-11020

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11020/
Summaries are generated and may contain mistakes; the official description above is the record.
