{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 2 products.","exploited":"There is no known exploitation of CVE-2020-11025 in the wild and no public exploit code.","fix":"Upgrade wordpress to 5.4.1 or later.","what":"CVE-2020-11025 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 30 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-11025 and fix it if it is affected.\n\nWhat it is: CVE-2020-11025 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 30 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-11025 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected from 4.7.0; fixed in 5.4.1\n- wordpress-multisite (Bitnami): affected from 4.7.0; fixed in 5.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-11025/ (Markdown: https://insights.sbomify.com/CVE-2020-11025/index.md)","id":"CVE-2020-11025","markdown":"https://insights.sbomify.com/CVE-2020-11025/index.md","name":"CVE-2020-11025","record":{"aliases":["BIT-wordpress-2020-11025","BIT-wordpress-multisite-2020-11025","DEBIAN-CVE-2020-11025","GHSA-4mhg-j6fx-5g3c","UBUNTU-CVE-2020-11025"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress CMS","requires_auth":"low_privilege","summary":"Authenticated attackers can execute arbitrary JavaScript via the WordPress Customizer navigation section, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"wordpress","vendor":"wordpress"}],"cvss":{"score":5.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In affected versions of WordPress, a cross-site scripting (XSS) vulnerability in the navigation section of Customizer allows JavaScript code to be executed. Exploitation requires an authenticated user. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Authenticated cross-site scripting (XSS) in WordPress Customizer","id":"CVE-2020-11025","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","wordpress:wordpress"],"type":"xss","year":"2020"},"n_packages":2,"n_references":3,"next":{"headline":"Specially crafted filenames in WordPress leading to XSS","id":"CVE-2020-11026"},"packages":[{"ecosystem":"Bitnami","fixed":["5.4.1"],"introduced":["4.7.0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2020-11025"},{"ecosystem":"Bitnami","fixed":["5.4.1"],"introduced":["4.7.0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2020-11025"}],"prev":{"headline":"Man-in-the-middle attack in Moonlight iOS/tvOS","id":"CVE-2020-11024"},"products":["WordPress"],"published":"2020-04-30","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["WordPress"]},"summary":"Authenticated attackers can execute arbitrary JavaScript via the WordPress Customizer navigation section, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2020-11025/"}