# CVE-2020-11025: Authenticated cross-site scripting (XSS) in WordPress Customizer

> Authenticated attackers can execute arbitrary JavaScript via the WordPress Customizer navigation section, potentially compromising user sessions.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-wordpress-2020-11025, BIT-wordpress-multisite-2020-11025, DEBIAN-CVE-2020-11025, GHSA-4mhg-j6fx-5g3c, UBUNTU-CVE-2020-11025

## What is CVE-2020-11025?

CVE-2020-11025 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 30 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In affected versions of WordPress, a cross-site scripting (XSS) vulnerability in the navigation section of Customizer allows JavaScript code to be executed. Exploitation requires an authenticated user. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-11025?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | From 4.7.0 | 5.4.1 |
| `wordpress-multisite` | Bitnami | From 4.7.0 | 5.4.1 |

Products: Debian Debian Linux, Wordpress Wordpress.

## How do I fix CVE-2020-11025?

Upgrade wordpress to 5.4.1 or later.

## Is CVE-2020-11025 being exploited?

There is no known exploitation of CVE-2020-11025 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11025 and fix it if it is affected.

What it is: CVE-2020-11025 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 30 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-11025 in the wild and no public exploit code.

Affected packages and fixed versions:
- wordpress (Bitnami): affected from 4.7.0; fixed in 5.4.1
- wordpress-multisite (Bitnami): affected from 4.7.0; fixed in 5.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11025/ (Markdown: https://insights.sbomify.com/CVE-2020-11025/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11025
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11025
- OSV: https://osv.dev/vulnerability/CVE-2020-11025

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11025/
Summaries are generated and may contain mistakes; the official description above is the record.
