CVE-2020-11028 Unauthenticated disclosure of certain private posts in WordPress
Unauthenticated attackers can view private posts that were previously public, exposing sensitive content to the public.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-11028?
CVE-2020-11028 is a medium-severity vulnerability in Debian Debian Linux, published on 30 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
In affected versions of WordPress, some private posts, which were previously public, can result in unauthenticated disclosure under a specific set of conditions. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).
Which versions are affected by CVE-2020-11028?
2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
wordpress Bitnami | All versions | 5.4.1 |
wordpress-multisite Bitnami | All versions | 5.4.1 |
Products include Debian Debian Linux, Wordpress Wordpress.
How do I fix CVE-2020-11028?
Upgrade wordpress to 5.4.1 or later.
Is CVE-2020-11028 being exploited?
There is no known exploitation of CVE-2020-11028 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-wordpress-2020-11028, BIT-wordpress-multisite-2020-11028, DEBIAN-CVE-2020-11028, GHSA-xhx9-759f-6p2w, UBUNTU-CVE-2020-11028.