CVE-2020-11030 Cross-site scripting (XSS) in Search block in WordPress
An authenticated user can execute arbitrary scripts via a crafted payload in the WordPress search block, potentially compromising other users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-11030?
CVE-2020-11030 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 30 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In affected versions of WordPress, a special payload can be crafted that can lead to scripts getting executed within the search block of the block editor. This requires an authenticated user with the ability to add content. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).
Which versions are affected by CVE-2020-11030?
2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
wordpress Bitnami | All versions | 5.4.1 |
wordpress-multisite Bitnami | All versions | 5.4.1 |
Products include Debian Debian Linux, Wordpress Wordpress.
How do I fix CVE-2020-11030?
Upgrade wordpress to 5.4.1 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-11030 being exploited?
There is no known exploitation of CVE-2020-11030 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-wordpress-2020-11030, BIT-wordpress-multisite-2020-11030, DEBIAN-CVE-2020-11030, GHSA-vccm-6gmc-qhjh, UBUNTU-CVE-2020-11030.