# CVE-2020-11034: bypass of manageRedirect in GLPI

> Attackers can bypass open redirect protections in GLPI, potentially redirecting users to malicious sites.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-gxv6-xq9q-37hg, UBUNTU-CVE-2020-11034

## What is CVE-2020-11034?

CVE-2020-11034 is a medium-severity vulnerability in Glpi-Project Glpi, published on 5 May 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In GLPI before version 9.4.6, there is a vulnerability that allows bypassing the open redirect protection based which is based on a regexp. This is fixed in version 9.4.6.

Weakness: CWE-601 (URL Redirection to Untrusted Site), CWE-185 (Incorrect Regular Expression)

## Which versions are affected by CVE-2020-11034?

It affects 1 product.


Products: Glpi-Project Glpi.

## How do I fix CVE-2020-11034?

Upgrade to a fixed version.

## Is CVE-2020-11034 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-11034 exists.

Public exploit code:

- GLPI <9.4.6 - Open Redirect (nuclei): http/cves/2020/CVE-2020-11034.yaml

## Other vulnerabilities in Glpi-Project Glpi

- [CVE-2022-35914](https://insights.sbomify.com/CVE-2022-35914/): Teclib GLPI Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2023-42802](https://insights.sbomify.com/CVE-2023-42802/): GLPI vulnerable to unallowed PHP script execution (critical 10.0)
- [CVE-2023-28849](https://insights.sbomify.com/CVE-2023-28849/): GLPI vulnerable to SQL injection and Stored XSS via inventory agent request (critical 10.0)
- [CVE-2022-35947](https://insights.sbomify.com/CVE-2022-35947/): SQL injection in GLPI (critical 10.0)
- [CVE-2022-31056](https://insights.sbomify.com/CVE-2022-31056/): SQL injection with _actor parameter in GLPI (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11034 and fix it if it is affected.

What it is: CVE-2020-11034 is a medium-severity vulnerability in Glpi-Project Glpi, published on 5 May 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-11034 exists.

Affected product: Glpi-Project Glpi. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11034/ (Markdown: https://insights.sbomify.com/CVE-2020-11034/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11034
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11034
- OSV: https://osv.dev/vulnerability/CVE-2020-11034

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11034/
Summaries are generated and may contain mistakes; the official description above is the record.
