{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-11036 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2020-11036 is a high-severity cross-site scripting vulnerability in Glpi-Project Glpi, published on 5 May 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-11036 and fix it if it is affected.\n\nWhat it is: CVE-2020-11036 is a high-severity cross-site scripting vulnerability in Glpi-Project Glpi, published on 5 May 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-11036 in the wild and no public exploit code.\n\nAffected product: Glpi-Project Glpi. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-11036/ (Markdown: https://insights.sbomify.com/CVE-2020-11036/index.md)","id":"CVE-2020-11036","markdown":"https://insights.sbomify.com/CVE-2020-11036/index.md","name":"CVE-2020-11036","record":{"aliases":["GHSA-3g3h-rwhr-7385","UBUNTU-CVE-2020-11036"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"ITSM web application","requires_auth":"low_privilege","summary":"Stored XSS in GLPI allows attackers to execute scripts in administrators' browsers via crafted user names or comments, potentially leading to session hijacking.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"glpi","vendor":"glpi-project"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In GLPI before version 9.4.6 there are multiple related stored XSS vulnerabilities. The package is vulnerable to Stored XSS in the comments of items in the Knowledge base. Adding a comment with content \"\u003cscript\u003ealert(1)\u003c/script\u003e\" reproduces the attack. This can be exploited by a user with administrator privileges in the User-Agent field. It can also be exploited by an outside party through the following steps: 1. Create a user with the surname `\" onmouseover=\"alert(document.cookie)` and an empty first name. 2. With this user, create a ticket 3. As an administrator (or other privileged user) open the created ticket 4. On the \"last update\" field, put your mouse on the name of the user 5. The XSS fires This is fixed in version 9.4.6.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XSS in GLPI","id":"CVE-2020-11036","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"glpi-project:glpi","products":["glpi-project:glpi"],"type":"xss","year":"2020"},"n_packages":0,"n_references":3,"next":{"headline":"Potential Observable Timing Discrepancy in Wagtail","id":"CVE-2020-11037"},"packages":[],"prev":{"headline":"weak CSRF tokens in GLPI","id":"CVE-2020-11035"},"products":["GLPI"],"published":"2020-05-05","related":[{"cvss_score":9.8,"headline":"Teclib GLPI Remote Code Execution","id":"CVE-2022-35914","kev_date_added":"2023-03-07","published":"2022-09-19"},{"cvss_score":10,"headline":"GLPI vulnerable to unallowed PHP script execution","id":"CVE-2023-42802","kev_date_added":null,"published":"2023-11-02"},{"cvss_score":10,"headline":"GLPI vulnerable to SQL injection and Stored XSS via inventory agent request","id":"CVE-2023-28849","kev_date_added":null,"published":"2023-04-05"},{"cvss_score":10,"headline":"SQL injection in GLPI","id":"CVE-2022-35947","kev_date_added":null,"published":"2022-09-14"},{"cvss_score":9.8,"headline":"SQL injection with _actor parameter in GLPI","id":"CVE-2022-31056","kev_date_added":null,"published":"2022-06-28"},{"cvss_score":9.8,"headline":"SQL injection on login page in GLPI","id":"CVE-2022-31061","kev_date_added":null,"published":"2022-06-28"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2021-44617","kev_date_added":null,"published":"2022-03-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["glpi-project"]},"summary":"Stored XSS in GLPI allows attackers to execute scripts in administrators' browsers via crafted user names or comments, potentially leading to session hijacking.","url":"https://insights.sbomify.com/CVE-2020-11036/"}