# CVE-2020-11036: XSS in GLPI

> Stored XSS in GLPI allows attackers to execute scripts in administrators' browsers via crafted user names or comments, potentially leading to session hijacking.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-3g3h-rwhr-7385, UBUNTU-CVE-2020-11036

## What is CVE-2020-11036?

CVE-2020-11036 is a high-severity cross-site scripting vulnerability in Glpi-Project Glpi, published on 5 May 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In GLPI before version 9.4.6 there are multiple related stored XSS vulnerabilities. The package is vulnerable to Stored XSS in the comments of items in the Knowledge base. Adding a comment with content "<script>alert(1)</script>" reproduces the attack. This can be exploited by a user with administrator privileges in the User-Agent field. It can also be exploited by an outside party through the following steps: 1. Create a user with the surname `" onmouseover="alert(document.cookie)` and an empty first name. 2. With this user, create a ticket 3. As an administrator (or other privileged user) open the created ticket 4. On the "last update" field, put your mouse on the name of the user 5. The XSS fires This is fixed in version 9.4.6.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-11036?

It affects 1 product.


Products: Glpi-Project Glpi.

## How do I fix CVE-2020-11036?

Upgrade to a fixed version.

## Is CVE-2020-11036 being exploited?

There is no known exploitation of CVE-2020-11036 in the wild and no public exploit code.

## Other vulnerabilities in Glpi-Project Glpi

- [CVE-2022-35914](https://insights.sbomify.com/CVE-2022-35914/): Teclib GLPI Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2023-42802](https://insights.sbomify.com/CVE-2023-42802/): GLPI vulnerable to unallowed PHP script execution (critical 10.0)
- [CVE-2023-28849](https://insights.sbomify.com/CVE-2023-28849/): GLPI vulnerable to SQL injection and Stored XSS via inventory agent request (critical 10.0)
- [CVE-2022-35947](https://insights.sbomify.com/CVE-2022-35947/): SQL injection in GLPI (critical 10.0)
- [CVE-2022-31056](https://insights.sbomify.com/CVE-2022-31056/): SQL injection with _actor parameter in GLPI (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11036 and fix it if it is affected.

What it is: CVE-2020-11036 is a high-severity cross-site scripting vulnerability in Glpi-Project Glpi, published on 5 May 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-11036 in the wild and no public exploit code.

Affected product: Glpi-Project Glpi. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11036/ (Markdown: https://insights.sbomify.com/CVE-2020-11036/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11036
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11036
- OSV: https://osv.dev/vulnerability/CVE-2020-11036

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11036/
Summaries are generated and may contain mistakes; the official description above is the record.
