# CVE-2020-11037: Potential Observable Timing Discrepancy in Wagtail

> An attacker on a local network can potentially recover shared passwords for protected pages via timing attacks in Wagtail CMS.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Apr 2020
- **Updated:** 19 Nov 2024
- **Also known as:** GHSA-jjjr-3jcw-f8v6, PYSEC-2020-153

## What is CVE-2020-11037?

CVE-2020-11037 is a medium-severity vulnerability in Wagtail, published on 30 Apr 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In Wagtail before versions 2.7.3 and 2.8.2, a potential timing attack exists on pages or documents that have been protected with a shared password through Wagtail's "Privacy" controls. This password check is performed through a character-by-character string comparison, and so an attacker who is able to measure the time taken by this check to a high degree of accuracy could potentially use timing differences to gain knowledge of the password. This is [understood to be feasible on a local network, but not on the public internet](https://groups.google.com/d/msg/django-developers/iAaq0pvHXuA/fpUuwjK3i2wJ).

Privacy settings that restrict access to pages/documents on a per-user or per-group basis (as opposed to a shared password) are unaffected by this vulnerability.

This has been patched in 2.7.3, 2.8.2, 2.9.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization), CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2020-11037?

7 open source packages ship an affected version, including wagtail. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wagtail` | PyPI | All versions | 2.7.3 |
| `wagtail` | PyPI | All versions | 2.7.3 |
| `wagtail` | PyPI | From 2.7 | 2.7.3, 2.8.2 |
| `wagtail` | PyPI | From 2.8rc1 | 2.8.2 |
| `wagtail` | PyPI | From 2.8rc1 | 2.8.2 |
| `wagtail` | PyPI | From 2.9rc1 | 2.9 |
| `wagtail` | PyPI | From 2.9rc1 | 2.9 |

Products: Torchbox Wagtail.

## How do I fix CVE-2020-11037?

Upgrade wagtail to a fixed version for your release line: 2.7.3, 2.8.2 or 2.9.

## Is CVE-2020-11037 being exploited?

There is no known exploitation of CVE-2020-11037 in the wild and no public exploit code.

## Other vulnerabilities in Wagtail

- [CVE-2026-54263](https://insights.sbomify.com/CVE-2026-54263/): Wagtail: Reflected XSS in dynamic image URL generator view (high 7.3)
- [CVE-2026-54261](https://insights.sbomify.com/CVE-2026-54261/): Wagtail: Improper permission handling in image preview (medium 6.5)
- [CVE-2026-44197](https://insights.sbomify.com/CVE-2026-44197/): Wagtail: Improper permission handling when comparing revisions (medium 6.5)
- [CVE-2026-44199](https://insights.sbomify.com/CVE-2026-44199/): Wagtail: Improper permission handling when deleting form submissions (medium 6.5)
- [CVE-2026-44200](https://insights.sbomify.com/CVE-2026-44200/): Wagtail: Improper permission handling when copying pages (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11037 and fix it if it is affected.

What it is: CVE-2020-11037 is a medium-severity vulnerability in Wagtail, published on 30 Apr 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-11037 in the wild and no public exploit code.

Affected packages and fixed versions:
- wagtail (PyPI): affected all versions; fixed in 2.7.3
- wagtail (PyPI): affected all versions; fixed in 2.7.3
- wagtail (PyPI): affected from 2.7; fixed in 2.7.3, 2.8.2
- wagtail (PyPI): affected from 2.8rc1; fixed in 2.8.2
- wagtail (PyPI): affected from 2.8rc1; fixed in 2.8.2
- wagtail (PyPI): affected from 2.9rc1; fixed in 2.9
- wagtail (PyPI): affected from 2.9rc1; fixed in 2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11037/ (Markdown: https://insights.sbomify.com/CVE-2020-11037/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11037
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11037
- OSV: https://osv.dev/vulnerability/CVE-2020-11037

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11037/
Summaries are generated and may contain mistakes; the official description above is the record.
