CVE-2020-11040 Out-of-bounds Read in FreeRDP

Low 2.2 Published Updated

An out-of-bounds read in FreeRDP allows attackers to disclose sensitive memory contents, requiring an upgrade to the patched version.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-11040?

CVE-2020-11040 is a low-severity vulnerability in Debian Debian Linux, published on 29 May 2020. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

In FreeRDP less than or equal to 2.0.0, there is an out-of-bound data read from memory in clear_decompress_subcode_rlex, visualized on screen as color. This has been patched in 2.1.0.

Weakness: CWE-125

Which versions are affected by CVE-2020-11040?

It affects 3 products.

Products include Debian Debian Linux, Freerdp Freerdp, Opensuse Leap.

How do I fix CVE-2020-11040?

Upgrade to a fixed version.

Is CVE-2020-11040 being exploited?

There is no known exploitation of CVE-2020-11040 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as DEBIAN-CVE-2020-11040, GHSA-x4wq-m7c9-rjgr, UBUNTU-CVE-2020-11040.

Is CVE-2020-11040 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free