{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2020-11040 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2020-11040 is a low-severity vulnerability in Debian Debian Linux, published on 29 May 2020. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-11040 and fix it if it is affected.\n\nWhat it is: CVE-2020-11040 is a low-severity vulnerability in Debian Debian Linux, published on 29 May 2020. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-11040 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-11040/ (Markdown: https://insights.sbomify.com/CVE-2020-11040/index.md)","id":"CVE-2020-11040","markdown":"https://insights.sbomify.com/CVE-2020-11040/index.md","name":"CVE-2020-11040","record":{"aliases":["DEBIAN-CVE-2020-11040","GHSA-x4wq-m7c9-rjgr","UBUNTU-CVE-2020-11040"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"FreeRDP library","requires_auth":"high_privilege","summary":"An out-of-bounds read in FreeRDP allows attackers to disclose sensitive memory contents, requiring an upgrade to the patched version.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"freerdp","vendor":"freerdp"},{"product":"leap","vendor":"opensuse"}],"cvss":{"score":2.2,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"In FreeRDP less than or equal to 2.0.0, there is an out-of-bound data read from memory in clear_decompress_subcode_rlex, visualized on screen as color. This has been patched in 2.1.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Out-of-bounds Read in FreeRDP","id":"CVE-2020-11040","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux","freerdp:freerdp","opensuse:leap"],"type":"information_disclosure","year":"2020"},"n_packages":0,"n_references":3,"next":{"headline":"Improper Validation of Array Index in FreeRDP","id":"CVE-2020-11041"},"packages":[],"prev":{"headline":"Integer Overflow in FreeRDP","id":"CVE-2020-11039"},"products":["FreeRDP"],"published":"2020-05-29","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["FreeRDP"]},"summary":"An out-of-bounds read in FreeRDP allows attackers to disclose sensitive memory contents, requiring an upgrade to the patched version.","url":"https://insights.sbomify.com/CVE-2020-11040/"}