CVE-2020-11041 Improper Validation of Array Index in FreeRDP

Low 2.2 Published Updated

An attacker can cause a FreeRDP client crash or session disconnect by exploiting an unchecked array index in the sound backend configuration.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-11041?

CVE-2020-11041 is a low-severity vulnerability in Debian Debian Linux, published on 29 May 2020. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

In FreeRDP less than or equal to 2.0.0, an outside controlled array index is used unchecked for data used as configuration for sound backend (alsa, oss, pulse, ...). The most likely outcome is a crash of the client instance followed by no or distorted sound or a session disconnect. If a user cannot upgrade to the patched version, a workaround is to disable sound for the session. This has been patched in 2.1.0.

Weakness: CWE-129

Which versions are affected by CVE-2020-11041?

It affects 3 products.

Products include Debian Debian Linux, Freerdp Freerdp, Opensuse Leap.

How do I fix CVE-2020-11041?

Upgrade to a fixed version.

Is CVE-2020-11041 being exploited?

There is no known exploitation of CVE-2020-11041 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as DEBIAN-CVE-2020-11041, GHSA-w67c-26c4-2h9w, UBUNTU-CVE-2020-11041.

Is CVE-2020-11041 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free