# CVE-2020-11042: Out-of-bounds Read in FreeRDP


- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 7 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-11042, GHSA-9jp6-5vf2-cx2q, UBUNTU-CVE-2020-11042

## What is CVE-2020-11042?

CVE-2020-11042 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 7 May 2020. 

### Official description

In FreeRDP greater than 1.1 and before 2.0.0, there is an out-of-bounds read in update_read_icon_info. It allows reading a attacker-defined amount of client memory (32bit unsigned -> 4GB) to an intermediate buffer. This can be used to crash the client or store information for later retrieval. This has been patched in 2.0.0.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2020-11042?

It affects 3 products.


Products: Canonical Ubuntu Linux, Debian Debian Linux, Freerdp Freerdp.

## How do I fix CVE-2020-11042?

Upgrade to a fixed version.

## Is CVE-2020-11042 being exploited?

There is no known exploitation of CVE-2020-11042 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11042 and fix it if it is affected.

What it is: CVE-2020-11042 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 7 May 2020. 
Exploitation: There is no known exploitation of CVE-2020-11042 in the wild and no public exploit code.

Affected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11042/ (Markdown: https://insights.sbomify.com/CVE-2020-11042/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11042
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11042
- OSV: https://osv.dev/vulnerability/CVE-2020-11042

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11042/
Summaries are generated and may contain mistakes; the official description above is the record.
