# CVE-2020-11043: Out-of-bounds Read in FreeRDP

> An out-of-bounds read in the FreeRDP RFX decoder allows attackers to cause screen corruption or potential information disclosure via invalid data.

- **Severity:** Low 2.2 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-11043, GHSA-5mr4-28w3-rc84, UBUNTU-CVE-2020-11043

## What is CVE-2020-11043?

CVE-2020-11043 is a low-severity memory corruption vulnerability in Debian Debian Linux, published on 29 May 2020. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

In FreeRDP less than or equal to 2.0.0, there is an out-of-bounds read in rfx_process_message_tileset. Invalid data fed to RFX decoder results in garbage on screen (as colors). This has been patched in 2.1.0.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2020-11043?

It affects 3 products.


Products: Debian Debian Linux, Freerdp Freerdp, Opensuse Leap.

## How do I fix CVE-2020-11043?

Upgrade to a fixed version.

## Is CVE-2020-11043 being exploited?

There is no known exploitation of CVE-2020-11043 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11043 and fix it if it is affected.

What it is: CVE-2020-11043 is a low-severity memory corruption vulnerability in Debian Debian Linux, published on 29 May 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-11043 in the wild and no public exploit code.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11043/ (Markdown: https://insights.sbomify.com/CVE-2020-11043/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11043
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11043
- OSV: https://osv.dev/vulnerability/CVE-2020-11043

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11043/
Summaries are generated and may contain mistakes; the official description above is the record.
