CVE-2020-11048 Out-of-bounds Read in FreeRDPrdp_read_flow_control_pdu

Low 2.2 Published Updated

An out-of-bounds read in FreeRDP allows attackers to abort sessions, causing denial of service without data extraction.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-11048?

CVE-2020-11048 is a low-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 7 May 2020. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

In FreeRDP after 1.0 and before 2.0.0, there is an out-of-bounds read. It only allows to abort a session. No data extraction is possible. This has been fixed in 2.0.0.

Weakness: CWE-125

Which versions are affected by CVE-2020-11048?

It affects 3 products.

Products include Canonical Ubuntu Linux, Debian Debian Linux, Freerdp Freerdp.

How do I fix CVE-2020-11048?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2020-11048 being exploited?

There is no known exploitation of CVE-2020-11048 in the wild and no public exploit code.

All Canonical Ubuntu Linux vulnerabilities

Sources

Also known as DEBIAN-CVE-2020-11048, GHSA-hv8w-f2hx-5gcv, UBUNTU-CVE-2020-11048.

Is CVE-2020-11048 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free