{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2020-11048 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2020-11048 is a low-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 7 May 2020. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-11048 and fix it if it is affected.\n\nWhat it is: CVE-2020-11048 is a low-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 7 May 2020. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-11048 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-11048/ (Markdown: https://insights.sbomify.com/CVE-2020-11048/index.md)","id":"CVE-2020-11048","markdown":"https://insights.sbomify.com/CVE-2020-11048/index.md","name":"CVE-2020-11048","record":{"aliases":["DEBIAN-CVE-2020-11048","GHSA-hv8w-f2hx-5gcv","UBUNTU-CVE-2020-11048"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"FreeRDP library","requires_auth":"high_privilege","summary":"An out-of-bounds read in FreeRDP allows attackers to abort sessions, causing denial of service without data extraction.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"freerdp","vendor":"freerdp"}],"cvss":{"score":2.2,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"In FreeRDP after 1.0 and before 2.0.0, there is an out-of-bounds read. It only allows to abort a session. No data extraction is possible. This has been fixed in 2.0.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Out-of-bounds Read in FreeRDPrdp_read_flow_control_pdu","id":"CVE-2020-11048","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","freerdp:freerdp"],"type":"denial_of_service","year":"2020"},"n_packages":0,"n_references":7,"next":{"headline":"Out-of-bounds Read in FreeRDPrdp_read_share_control_header","id":"CVE-2020-11049"},"packages":[],"prev":{"headline":"Out-of-bounds Read in FreeRDP","id":"CVE-2020-11047"},"products":["FreeRDP"],"published":"2020-05-07","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["FreeRDP"]},"summary":"An out-of-bounds read in FreeRDP allows attackers to abort sessions, causing denial of service without data extraction.","url":"https://insights.sbomify.com/CVE-2020-11048/"}