{"answers":{"affected":"2 open source packages ship an affected version, including sorcery. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-11052 in the wild and no public exploit code.","fix":"Upgrade sorcery to 0.15.0 or later.","what":"CVE-2020-11052 is a high-severity vulnerability in Sorcery, published on 7 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-11052 and fix it if it is affected.\n\nWhat it is: CVE-2020-11052 is a high-severity vulnerability in Sorcery, published on 7 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-11052 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sorcery (RubyGems): affected all versions; fixed in 0.15.0\n- sorcery (RubyGems): affected all versions; fixed in 0.15.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-11052/ (Markdown: https://insights.sbomify.com/CVE-2020-11052/index.md)","id":"CVE-2020-11052","markdown":"https://insights.sbomify.com/CVE-2020-11052/index.md","name":"CVE-2020-11052","record":{"aliases":["GHSA-jc8m-cxhj-668x"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Ruby authentication library","requires_auth":"none","summary":"Attackers can bypass brute force protection in Sorcery after lockout expiry, enabling account takeover via password guessing.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sorcery","vendor":"sorcery_project"}],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-307","name":"Improper Restriction of Excessive Authentication Attempts"}],"description":"In Sorcery before 0.15.0, there is a brute force vulnerability when using password authentication via Sorcery. The brute force protection submodule will prevent a brute force attack for the defined lockout period, but once expired, protection will not be re-enabled until a user or malicious actor logs in successfully. This does not affect users that do not use the built-in brute force protection submodule, nor users that use permanent account lockout. This has been patched in 0.15.0.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Restriction of Excessive Authentication Attempts in Sorcery","id":"CVE-2020-11052","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"security_feature_bypass","year":"2020"},"n_packages":2,"n_references":4,"next":{"headline":"Open Redirect in OAuth2 Proxy","id":"CVE-2020-11053"},"packages":[{"ecosystem":"RubyGems","fixed":["0.15.0"],"introduced":["0"],"last_affected":[],"package":"sorcery","purl":null,"source":"GHSA-jc8m-cxhj-668x"},{"ecosystem":"RubyGems","fixed":["0.15.0"],"introduced":["0"],"last_affected":[],"package":"sorcery","purl":"pkg:gem/sorcery","source":"GHSA-jc8m-cxhj-668x"}],"prev":{"headline":"XSS in Wiki.js","id":"CVE-2020-11051"},"products":["Sorcery"],"published":"2020-05-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Sorcery"]},"summary":"Attackers can bypass brute force protection in Sorcery after lockout expiry, enabling account takeover via password guessing.","url":"https://insights.sbomify.com/CVE-2020-11052/"}