# CVE-2020-11052: Improper Restriction of Excessive Authentication Attempts in Sorcery

> Attackers can bypass brute force protection in Sorcery after lockout expiry, enabling account takeover via password guessing.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-jc8m-cxhj-668x

## What is CVE-2020-11052?

CVE-2020-11052 is a high-severity vulnerability in Sorcery, published on 7 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Sorcery before 0.15.0, there is a brute force vulnerability when using password authentication via Sorcery. The brute force protection submodule will prevent a brute force attack for the defined lockout period, but once expired, protection will not be re-enabled until a user or malicious actor logs in successfully. This does not affect users that do not use the built-in brute force protection submodule, nor users that use permanent account lockout. This has been patched in 0.15.0.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2020-11052?

2 open source packages ship an affected version, including sorcery. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sorcery` | RubyGems | All versions | 0.15.0 |
| `sorcery` | RubyGems | All versions | 0.15.0 |

Products: Sorcery Project Sorcery.

## How do I fix CVE-2020-11052?

Upgrade sorcery to 0.15.0 or later.

## Is CVE-2020-11052 being exploited?

There is no known exploitation of CVE-2020-11052 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11052 and fix it if it is affected.

What it is: CVE-2020-11052 is a high-severity vulnerability in Sorcery, published on 7 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-11052 in the wild and no public exploit code.

Affected packages and fixed versions:
- sorcery (RubyGems): affected all versions; fixed in 0.15.0
- sorcery (RubyGems): affected all versions; fixed in 0.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11052/ (Markdown: https://insights.sbomify.com/CVE-2020-11052/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11052
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11052
- OSV: https://osv.dev/vulnerability/CVE-2020-11052

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11052/
Summaries are generated and may contain mistakes; the official description above is the record.
