# CVE-2020-11054: Incorrect Provision of Specified Functionality in qutebrowser

> qutebrowser incorrectly displays a green URL after reloading a page with certificate errors, potentially misleading users about connection security.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-11054, GHSA-4rcq-jv2f-898j, PYSEC-2020-97, UBUNTU-CVE-2020-11054

## What is CVE-2020-11054?

CVE-2020-11054 is a low-severity vulnerability in Fedoraproject Fedora, published on 7 May 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In qutebrowser versions less than 1.11.1, reloading a page with certificate errors shows a green URL. After a certificate error was overridden by the user, qutebrowser displays the URL as yellow (colors.statusbar.url.warn.fg). However, when the affected website was subsequently loaded again, the URL was mistakenly displayed as green (colors.statusbar.url.success_https). While the user already has seen a certificate error prompt at this point (or set content.ssl_strict to false, which is not recommended), this could still provide a false sense of security. This has been fixed in 1.11.1 and 1.12.0. All versions of qutebrowser are believed to be affected, though versions before v0.11.x couldn't be tested. Backported patches for older versions (greater than or equal to 1.4.0 and less than or equal to 1.10.2) are available, but no further releases are planned.

Weakness: CWE-684 (Incorrect Provision of Specified Functionality)

## Which versions are affected by CVE-2020-11054?

3 open source packages ship an affected version, including qutebrowser. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `qutebrowser` | PyPI | All versions | 1.11.0 |
| `qutebrowser` | PyPI | All versions | 1.11.1 |
| `qutebrowser` | PyPI | All versions | 1.11.1 |

Products: Fedoraproject Fedora, Qutebrowser Qutebrowser.

## How do I fix CVE-2020-11054?

Upgrade qutebrowser to a fixed version for your release line: 1.11.0 or 1.11.1.

## Is CVE-2020-11054 being exploited?

There is no known exploitation of CVE-2020-11054 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11054 and fix it if it is affected.

What it is: CVE-2020-11054 is a low-severity vulnerability in Fedoraproject Fedora, published on 7 May 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-11054 in the wild and no public exploit code.

Affected packages and fixed versions:
- qutebrowser (PyPI): affected all versions; fixed in 1.11.0
- qutebrowser (PyPI): affected all versions; fixed in 1.11.1
- qutebrowser (PyPI): affected all versions; fixed in 1.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11054/ (Markdown: https://insights.sbomify.com/CVE-2020-11054/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11054
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11054
- OSV: https://osv.dev/vulnerability/CVE-2020-11054

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11054/
Summaries are generated and may contain mistakes; the official description above is the record.
