# CVE-2020-11056: Potential Code Injection in Sprout Forms

> Attackers can execute arbitrary Twig code via custom fields in notification emails, potentially compromising the server.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-px8v-hxxx-2rgh

## What is CVE-2020-11056?

CVE-2020-11056 is a high-severity code injection vulnerability in barrelstrength Sprout Forms, published on 7 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Sprout Forms before 3.9.0, there is a potential Server-Side Template Injection vulnerability when using custom fields in Notification Emails which could lead to the execution of Twig code. This has been fixed in 3.9.0.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2020-11056?

4 open source packages ship an affected version, including barrelstrength/sprout-forms and barrelstrength/sprout-base-email. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `barrelstrength/sprout-forms` | Packagist | All versions | 3.9.0 |
| `barrelstrength/sprout-forms` | Packagist | All versions | 3.9.0 |
| `barrelstrength/sprout-base-email` | Packagist | All versions | 1.2.7 |
| `barrelstrength/sprout-base-email` | Packagist | All versions | 1.2.7 |

Products: Barrelstrengthdesign Sprout Forms.

## How do I fix CVE-2020-11056?

Upgrade barrelstrength/sprout-forms to 3.9.0 or later.

## Is CVE-2020-11056 being exploited?

There is no known exploitation of CVE-2020-11056 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11056 and fix it if it is affected.

What it is: CVE-2020-11056 is a high-severity code injection vulnerability in barrelstrength Sprout Forms, published on 7 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-11056 in the wild and no public exploit code.

Affected packages and fixed versions:
- barrelstrength/sprout-forms (Packagist): affected all versions; fixed in 3.9.0
- barrelstrength/sprout-forms (Packagist): affected all versions; fixed in 3.9.0
- barrelstrength/sprout-base-email (Packagist): affected all versions; fixed in 1.2.7
- barrelstrength/sprout-base-email (Packagist): affected all versions; fixed in 1.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11056/ (Markdown: https://insights.sbomify.com/CVE-2020-11056/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11056
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11056
- OSV: https://osv.dev/vulnerability/CVE-2020-11056

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11056/
Summaries are generated and may contain mistakes; the official description above is the record.
