CVE-2020-11058 Improper Restriction of Operations within the Bounds of a Memory Buffer in FreeRDP

Low 2.2 Published Updated

A manipulated client or server can trigger an out-of-bounds read in FreeRDP, causing a disconnect and denial of service.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-11058?

CVE-2020-11058 is a low-severity memory corruption vulnerability in Canonical Ubuntu Linux, published on 12 May 2020. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

In FreeRDP after 1.1 and before 2.0.0, a stream out-of-bounds seek in rdp_read_font_capability_set could lead to a later out-of-bounds read. As a result, a manipulated client or server might force a disconnect due to an invalid data read. This has been fixed in 2.0.0.

Weakness: CWE-125, CWE-119

Which versions are affected by CVE-2020-11058?

It affects 3 products.

Products include Canonical Ubuntu Linux, Debian Debian Linux, Freerdp Freerdp.

How do I fix CVE-2020-11058?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2020-11058 being exploited?

There is no known exploitation of CVE-2020-11058 in the wild and no public exploit code.

All Canonical Ubuntu Linux vulnerabilities

Sources

Also known as DEBIAN-CVE-2020-11058, GHSA-wjg2-2f82-466g, UBUNTU-CVE-2020-11058.

Is CVE-2020-11058 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free