# CVE-2020-11068: Potential Buffer Overflow in LoRaMac-node

> Attackers can trigger a buffer overflow in LoRaMac-node by sending oversized packets, potentially leading to code execution or crashes.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 23 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-559p-6xgm-fpv9

## What is CVE-2020-11068?

CVE-2020-11068 is a medium-severity memory corruption vulnerability in LoRaMac-node, published on 23 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In LoRaMac-node before 4.4.4, a reception buffer overflow can happen due to the received buffer size not being checked. This has been fixed in 4.4.4.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2020-11068?

It affects 1 product.


Products: Semtech Loramac-Node.

## How do I fix CVE-2020-11068?

No fix has been published for CVE-2020-11068 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-11068 being exploited?

There is no known exploitation of CVE-2020-11068 in the wild and no public exploit code.

## Other vulnerabilities in LoRaMac-node

- [CVE-2022-39274](https://insights.sbomify.com/CVE-2022-39274/): Buffer Overflow in `ProcessRadioRxDone` in LoRaMac-node (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11068 and fix it if it is affected.

What it is: CVE-2020-11068 is a medium-severity memory corruption vulnerability in LoRaMac-node, published on 23 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-11068 in the wild and no public exploit code.

Affected product: LoRaMac-node. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11068/ (Markdown: https://insights.sbomify.com/CVE-2020-11068/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11068
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11068
- OSV: https://osv.dev/vulnerability/CVE-2020-11068

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11068/
Summaries are generated and may contain mistakes; the official description above is the record.
