# CVE-2020-11071: False-negative validation results in MINT transactions with invalid baton

> A logic flaw in SLPJS allows false-negative validation of MINT transactions, potentially leading to the destruction of a user's minting baton.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-jc83-cpf9-q7c6

## What is CVE-2020-11071?

CVE-2020-11071 is a high-severity vulnerability in simpleledger slpjs, published on 12 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SLPJS (npm package slpjs) before version 0.27.2, has a vulnerability where users could experience false-negative validation outcomes for MINT transaction operations. A poorly implemented SLP wallet could allow spending of the affected tokens which would result in the destruction of a user's minting baton. This is fixed in version 0.27.2.

Weakness: CWE-697 (Incorrect Comparison)

## Which versions are affected by CVE-2020-11071?

2 open source packages ship an affected version, including slpjs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `slpjs` | npm | All versions | 0.27.2 |
| `slpjs` | npm | All versions | 0.27.2 |

Products: Simpleledger Slpjs.

## How do I fix CVE-2020-11071?

Upgrade slpjs to 0.27.2 or later.

## Is CVE-2020-11071 being exploited?

There is no known exploitation of CVE-2020-11071 in the wild and no public exploit code.

## Other vulnerabilities in simpleledger slpjs

- [CVE-2020-15130](https://insights.sbomify.com/CVE-2020-15130/): False-positive validity for NFT1 genesis transactions in SLPJS (high 7.5)
- [CVE-2019-16762](https://insights.sbomify.com/CVE-2019-16762/): Validator parsing discrepancy due to string encoding in NPM slpjs (medium 5.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11071 and fix it if it is affected.

What it is: CVE-2020-11071 is a high-severity vulnerability in simpleledger slpjs, published on 12 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-11071 in the wild and no public exploit code.

Affected packages and fixed versions:
- slpjs (npm): affected all versions; fixed in 0.27.2
- slpjs (npm): affected all versions; fixed in 0.27.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11071/ (Markdown: https://insights.sbomify.com/CVE-2020-11071/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11071
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11071
- OSV: https://osv.dev/vulnerability/CVE-2020-11071

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11071/
Summaries are generated and may contain mistakes; the official description above is the record.
