{"answers":{"affected":"2 open source packages ship an affected version, including slp-validate. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-11072 in the wild and no public exploit code.","fix":"Upgrade slp-validate to 1.2.1 or later.","what":"CVE-2020-11072 is a high-severity vulnerability in simpleledger slp-validate, published on 12 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-11072 and fix it if it is affected.\n\nWhat it is: CVE-2020-11072 is a high-severity vulnerability in simpleledger slp-validate, published on 12 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-11072 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- slp-validate (npm): affected all versions; fixed in 1.2.1\n- slp-validate (npm): affected all versions; fixed in 1.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-11072/ (Markdown: https://insights.sbomify.com/CVE-2020-11072/index.md)","id":"CVE-2020-11072","markdown":"https://insights.sbomify.com/CVE-2020-11072/index.md","name":"CVE-2020-11072","record":{"aliases":["GHSA-4w97-57v2-3w44"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"SLP validation library","requires_auth":"none","summary":"A logic flaw in SLP validation allows invalid minting transactions to pass, potentially destroying user minting batons if wallets rely on this library.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"slp-validate","vendor":"simpleledger"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-697","name":"Incorrect Comparison"}],"description":"In SLP Validate (npm package slp-validate) before version 1.2.1, users could experience false-negative validation outcomes for MINT transaction operations. A poorly implemented SLP wallet could allow spending of the affected tokens which would result in the destruction of a user's minting baton. This has been fixed in slp-validate in version 1.2.1. Additonally, slpjs version 0.27.2 has a related fix under related CVE-2020-11071.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"False-negative validation results in MINT transactions with invalid baton","id":"CVE-2020-11072","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"business_logic","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Remote Code Execution in Autoswitch Python Virtualenv","id":"CVE-2020-11073"},"packages":[{"ecosystem":"npm","fixed":["1.2.1"],"introduced":["0"],"last_affected":[],"package":"slp-validate","purl":null,"source":"GHSA-4w97-57v2-3w44"},{"ecosystem":"npm","fixed":["1.2.1"],"introduced":["0"],"last_affected":[],"package":"slp-validate","purl":"pkg:npm/slp-validate","source":"GHSA-4w97-57v2-3w44"}],"prev":{"headline":"False-negative validation results in MINT transactions with invalid baton","id":"CVE-2020-11071"},"products":["slp-validate"],"published":"2020-05-12","related":[{"cvss_score":7.5,"headline":"False-positive validity for NFT1 genesis transactions in SLP Validate","id":"CVE-2020-15131","kev_date_added":null,"published":"2020-07-30"},{"cvss_score":5.7,"headline":"Validator parsing discrepancy due to string encoding in NPM slp-validate 1.0.0","id":"CVE-2019-16761","kev_date_added":null,"published":"2019-11-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["simpleledger"]},"summary":"A logic flaw in SLP validation allows invalid minting transactions to pass, potentially destroying user minting batons if wallets rely on this library.","url":"https://insights.sbomify.com/CVE-2020-11072/"}