CVE-2020-11074 Stored XSS in PrestaShop

Medium 5.4 Published Updated

Attackers can inject malicious scripts via quick access item names, potentially stealing user sessions or executing code in PrestaShop stores.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2020-11074?

CVE-2020-11074 is a medium-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 2 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

In PrestaShop from version 1.5.3.0 and before version 1.7.6.6, there is a stored XSS when using the name of a quick access item. The problem is fixed in 1.7.6.6.

Weakness: CWE-79

Which versions are affected by CVE-2020-11074?

It affects 1 product.

Products include Prestashop Prestashop.

How do I fix CVE-2020-11074?

No fix has been published for CVE-2020-11074 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-11074 being exploited?

There is no known exploitation of CVE-2020-11074 in the wild and no public exploit code.

All Prestashop Prestashop vulnerabilities

Sources

Also known as GHSA-v4pg-q2cv-f7x4.

Is CVE-2020-11074 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free