# CVE-2020-11077: HTTP Smuggling via Transfer-Encoding Header in Puma

> Attackers can smuggle HTTP requests via Transfer-Encoding headers, causing responses to be sent to wrong clients, leading to data leakage.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 May 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-11077, GHSA-w64w-qqph-5gxm, UBUNTU-CVE-2020-11077

## What is CVE-2020-11077?

CVE-2020-11077 is a medium-severity vulnerability in Debian Debian Linux, published on 22 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Puma (RubyGem) before 4.3.5 and 3.12.6, a client could smuggle a request through a proxy, causing the proxy to send a response back to another unknown client. If the proxy uses persistent connections and the client adds another request in via HTTP pipelining, the proxy may mistake it as the first request's body. Puma, however, would see it as two requests, and when processing the second request, send back a response that the proxy does not expect. If the proxy has reused the persistent connection to Puma to send another request for a different client, the second response from the first client will be sent to the second client. This is a similar but different vulnerability from CVE-2020-11076. The problem has been fixed in Puma 3.12.6 and Puma 4.3.5.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2020-11077?

4 open source packages ship an affected version, including puma. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `puma` | RubyGems | All versions | 3.12.6 |
| `puma` | RubyGems | All versions | 3.12.6 |
| `puma` | RubyGems | From 4.0.0 | 4.3.5 |
| `puma` | RubyGems | From 4.0.0 | 4.3.5 |

Products: Debian Debian Linux, Fedoraproject Fedora, Opensuse Leap, Puma Puma.

## How do I fix CVE-2020-11077?

Upgrade puma to a fixed version for your release line: 3.12.6 or 4.3.5.

## Is CVE-2020-11077 being exploited?

There is no known exploitation of CVE-2020-11077 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11077 and fix it if it is affected.

What it is: CVE-2020-11077 is a medium-severity vulnerability in Debian Debian Linux, published on 22 May 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-11077 in the wild and no public exploit code.

Affected packages and fixed versions:
- puma (RubyGems): affected all versions; fixed in 3.12.6
- puma (RubyGems): affected all versions; fixed in 3.12.6
- puma (RubyGems): affected from 4.0.0; fixed in 4.3.5
- puma (RubyGems): affected from 4.0.0; fixed in 4.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11077/ (Markdown: https://insights.sbomify.com/CVE-2020-11077/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11077
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11077
- OSV: https://osv.dev/vulnerability/CVE-2020-11077

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11077/
Summaries are generated and may contain mistakes; the official description above is the record.
