{"answers":{"affected":"2 open source packages ship an affected version, including kaminari. It affects 2 products.","exploited":"There is no known exploitation of CVE-2020-11082 in the wild and no public exploit code.","fix":"Upgrade kaminari to 1.2.1 or later.","what":"CVE-2020-11082 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 28 May 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-11082 and fix it if it is affected.\n\nWhat it is: CVE-2020-11082 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 28 May 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-11082 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- kaminari (RubyGems): affected all versions; fixed in 1.2.1\n- kaminari (RubyGems): affected all versions; fixed in 1.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-11082/ (Markdown: https://insights.sbomify.com/CVE-2020-11082/index.md)","id":"CVE-2020-11082","markdown":"https://insights.sbomify.com/CVE-2020-11082/index.md","name":"CVE-2020-11082","record":{"aliases":["DEBIAN-CVE-2020-11082","DLA-2763-1","DSA-5005-1","GHSA-r5jw-62xg-j433","UBUNTU-CVE-2020-11082"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby pagination library","requires_auth":"none","summary":"An attacker can inject arbitrary code into pages with pagination links in the Kaminari Ruby library, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"kaminari","vendor":"kaminari_project"}],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In Kaminari before 1.2.1, there is a vulnerability that would allow an attacker to inject arbitrary code into pages with pagination links. This has been fixed in 1.2.1.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Scripting in Kaminari","id":"CVE-2020-11082","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"xss","year":"2020"},"n_packages":2,"n_references":5,"next":{"headline":"Stored XSS in October","id":"CVE-2020-11083"},"packages":[{"ecosystem":"RubyGems","fixed":["1.2.1"],"introduced":["0"],"last_affected":[],"package":"kaminari","purl":null,"source":"GHSA-r5jw-62xg-j433"},{"ecosystem":"RubyGems","fixed":["1.2.1"],"introduced":["0"],"last_affected":[],"package":"kaminari","purl":"pkg:gem/kaminari","source":"GHSA-r5jw-62xg-j433"}],"prev":{"headline":"osquery susceptible to DLL search order hijacking of zlib1.dll","id":"CVE-2020-11081"},"products":["Kaminari"],"published":"2020-05-28","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["kaminari"]},"summary":"An attacker can inject arbitrary code into pages with pagination links in the Kaminari Ruby library, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2020-11082/"}