CVE-2020-11087 Out-of-bounds Read in FreeRDP

Low 3.1 Published Updated

An out-of-bounds read in FreeRDP allows attackers to disclose sensitive memory or cause a denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-11087?

CVE-2020-11087 is a low-severity vulnerability in Debian Debian Linux, published on 29 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In FreeRDP less than or equal to 2.0.0, there is an out-of-bound read in ntlm_read_AuthenticateMessage. This has been fixed in 2.1.0.

Weakness: CWE-125

Which versions are affected by CVE-2020-11087?

It affects 3 products.

Products include Debian Debian Linux, Freerdp Freerdp, Opensuse Leap.

How do I fix CVE-2020-11087?

Upgrade to a fixed version.

Is CVE-2020-11087 being exploited?

There is no known exploitation of CVE-2020-11087 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as DEBIAN-CVE-2020-11087, GHSA-84vj-g73m-chw7, UBUNTU-CVE-2020-11087.

Is CVE-2020-11087 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free