CVE-2020-11088 Out-of-bound read in FreeRDP

Low 3.1 Published Updated

An out-of-bounds read in FreeRDP allows attackers to cause denial of service or disclose sensitive information via crafted NTLM messages.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-11088?

CVE-2020-11088 is a low-severity memory corruption vulnerability in Debian Debian Linux, published on 29 May 2020. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In FreeRDP less than or equal to 2.0.0, there is an out-of-bound read in ntlm_read_NegotiateMessage. This has been fixed in 2.1.0.

Weakness: CWE-125

Which versions are affected by CVE-2020-11088?

It affects 3 products.

Products include Debian Debian Linux, Freerdp Freerdp, Opensuse Leap.

How do I fix CVE-2020-11088?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2020-11088 being exploited?

There is no known exploitation of CVE-2020-11088 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as DEBIAN-CVE-2020-11088, GHSA-xh4f-fh87-43hp, UBUNTU-CVE-2020-11088.

Is CVE-2020-11088 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free