CVE-2020-11090 Uncontrolled Resource Consumption in Indy Node

High 7.5 Published Updated

A malformed transaction can crash the primary node, causing repeated view changes that potentially bring down the entire network.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-11090?

CVE-2020-11090 is a high-severity denial of service vulnerability in Hyperledger Indy Node, published on 11 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

In Indy Node 1.12.2, there is an Uncontrolled Resource Consumption vulnerability. Indy Node has a bug in TAA handling code. The current primary can be crashed with a malformed transaction from a client, which leads to a view change. Repeated rapid view changes have the potential of bringing down the network. This is fixed in version 1.12.3.

Weakness: CWE-400

Which versions are affected by CVE-2020-11090?

3 open source packages ship an affected version, including indy-node. It affects 1 product.

PackageAffectedFixed in
indy-node PyPIAll versions1.12.3
indy-node PyPIFrom 1.12.21.12.3
indy-node PyPIFrom 1.12.21.12.3

Products include Linuxfoundation Indy-Node.

How do I fix CVE-2020-11090?

Upgrade indy-node to 1.12.3 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2020-11090 being exploited?

There is no known exploitation of CVE-2020-11090 in the wild and no public exploit code.

Sources

Also known as GHSA-3gw4-m5w7-v89c, PYSEC-2020-47.

Is CVE-2020-11090 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free