{"answers":{"affected":"3 open source packages ship an affected version, including indy-node. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-11090 in the wild and no public exploit code.","fix":"Upgrade indy-node to 1.12.3 or later.","what":"CVE-2020-11090 is a high-severity denial of service vulnerability in Hyperledger Indy Node, published on 11 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-11090 and fix it if it is affected.\n\nWhat it is: CVE-2020-11090 is a high-severity denial of service vulnerability in Hyperledger Indy Node, published on 11 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-11090 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- indy-node (PyPI): affected all versions; fixed in 1.12.3\n- indy-node (PyPI): affected from 1.12.2; fixed in 1.12.3\n- indy-node (PyPI): affected from 1.12.2; fixed in 1.12.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-11090/ (Markdown: https://insights.sbomify.com/CVE-2020-11090/index.md)","id":"CVE-2020-11090","markdown":"https://insights.sbomify.com/CVE-2020-11090/index.md","name":"CVE-2020-11090","record":{"aliases":["GHSA-3gw4-m5w7-v89c","PYSEC-2020-47"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Indy Node","requires_auth":"none","summary":"A malformed transaction can crash the primary node, causing repeated view changes that potentially bring down the entire network.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"indy-node","vendor":"linuxfoundation"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"In Indy Node 1.12.2, there is an Uncontrolled Resource Consumption vulnerability. Indy Node has a bug in TAA handling code. The current primary can be crashed with a malformed transaction from a client, which leads to a view change. Repeated rapid view changes have the potential of bringing down the network. This is fixed in version 1.12.3.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Uncontrolled Resource Consumption in Indy Node","id":"CVE-2020-11090","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2020"},"n_packages":3,"n_references":3,"next":{"headline":"Weave Net clusters susceptible to MitM attacks via IPv6 rogue router advertisements","id":"CVE-2020-11091"},"packages":[{"ecosystem":"PyPI","fixed":["1.12.3"],"introduced":["0"],"last_affected":[],"package":"indy-node","purl":"pkg:pypi/indy-node","source":"PYSEC-2020-47"},{"ecosystem":"PyPI","fixed":["1.12.3"],"introduced":["1.12.2"],"last_affected":[],"package":"indy-node","purl":null,"source":"GHSA-3gw4-m5w7-v89c"},{"ecosystem":"PyPI","fixed":["1.12.3"],"introduced":["1.12.2"],"last_affected":[],"package":"indy-node","purl":"pkg:pypi/indy-node","source":"GHSA-3gw4-m5w7-v89c"}],"prev":{"headline":"Out-of-bound read in FreeRDP","id":"CVE-2020-11089"},"products":["Indy Node"],"published":"2020-06-11","related":[{"cvss_score":8.8,"headline":"Remote code execution in Indy's NODE_UPGRADE transaction","id":"CVE-2022-31020","kev_date_added":null,"published":"2022-09-06"},{"cvss_score":7.5,"headline":"Hyperledger Indy DOS vulnerability","id":"CVE-2022-31006","kev_date_added":null,"published":"2022-09-09"},{"cvss_score":7.5,"headline":"Authorization bypass in Hyperledger Indy","id":"CVE-2020-11093","kev_date_added":null,"published":"2020-12-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Hyperledger"]},"summary":"A malformed transaction can crash the primary node, causing repeated view changes that potentially bring down the entire network.","url":"https://insights.sbomify.com/CVE-2020-11090/"}