# CVE-2020-11091: Weave Net clusters susceptible to MitM attacks via IPv6 rogue router advertisements

> An attacker with root in a container can send rogue IPv6 router advertisements to intercept host traffic, enabling man-in-the-middle attacks and potential host compromise.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-59qg-grp7-5r73, GO-2022-0794

## What is CVE-2020-11091?

CVE-2020-11091 is a medium-severity vulnerability in weaveworks Weave, published on 3 Jun 2020. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

In Weave Net before version 2.6.3, an attacker able to run a process as root in a container is able to respond to DNS requests from the host and thereby insert themselves as a fake service. In a cluster with an IPv4 internal network, if IPv6 is not totally disabled on the host (via ipv6.disable=1 on the kernel cmdline), it will be either unconfigured or configured on some interfaces, but it's pretty likely that ipv6 forwarding is disabled, ie /proc/sys/net/ipv6/conf//forwarding == 0. Also by default, /proc/sys/net/ipv6/conf//accept_ra == 1. The combination of these 2 sysctls means that the host accepts router advertisements and configure the IPv6 stack using them. By sending rogue router advertisements, an attacker can reconfigure the host to redirect part or all of the IPv6 traffic of the host to the attacker controlled container. Even if there was no IPv6 traffic before, if the DNS returns A (IPv4) and AAAA (IPv6) records, many HTTP libraries will try to connect via IPv6 first then fallback to IPv4, giving an opportunity to the attacker to respond. If by chance you also have on the host a vulnerability like last year's RCE in apt (CVE-2019-3462), you can now escalate to the host. Weave Net version 2.6.3 disables the accept_ra option on the veth devices that it creates.

Weakness: CWE-350 (Reliance on Reverse DNS Resolution for a Security-Critical Action)

## Which versions are affected by CVE-2020-11091?

3 open source packages ship an affected version, including github.com/weaveworks/weave. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/weaveworks/weave` | Go | All versions | 2.6.3 |
| `github.com/weaveworks/weave` | Go | All versions | 2.6.3 |
| `github.com/weaveworks/weave` | Go | All versions | 2.6.3+incompatible |

Products: Weave Weave Net.

## How do I fix CVE-2020-11091?

Upgrade github.com/weaveworks/weave to a fixed version for your release line: 2.6.3 or 2.6.3+incompatible.

## Is CVE-2020-11091 being exploited?

There is no known exploitation of CVE-2020-11091 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11091 and fix it if it is affected.

What it is: CVE-2020-11091 is a medium-severity vulnerability in weaveworks Weave, published on 3 Jun 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-11091 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/weaveworks/weave (Go): affected all versions; fixed in 2.6.3
- github.com/weaveworks/weave (Go): affected all versions; fixed in 2.6.3
- github.com/weaveworks/weave (Go): affected all versions; fixed in 2.6.3+incompatible

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11091/ (Markdown: https://insights.sbomify.com/CVE-2020-11091/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11091
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11091
- OSV: https://osv.dev/vulnerability/CVE-2020-11091

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11091/
Summaries are generated and may contain mistakes; the official description above is the record.
