# CVE-2020-11100: Memory corruption in n/a

> A remote attacker can achieve arbitrary code execution by sending a crafted HTTP/2 request that triggers a heap buffer overflow in the HPACK decoder.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2020-11100, BIT-haproxy-2020-11100, CLEANSTART-2026-RO35249, DEBIAN-CVE-2020-11100, DSA-4649-1, GHSA-3xcv-57q9-hrj2, RHSA-2020:1288, RHSA-2020:1289, RHSA-2020:1290, SUSE-SU-2020:0851-1, SUSE-SU-2020:0852-1, UBUNTU-CVE-2020-11100, USN-4321-1, openSUSE-SU-2020:0444-1

## What is CVE-2020-11100?

CVE-2020-11100 is a high-severity memory corruption vulnerability in Canonical Ubuntu Linux, published on 2 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In hpack_dht_insert in hpack-tbl.c in the HPACK decoder in HAProxy 1.8 through 2.x before 2.1.4, a remote attacker can write arbitrary bytes around a certain location on the heap via a crafted HTTP/2 request, possibly causing remote code execution.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2020-11100?

1 open source package ship an affected version, including haproxy. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `haproxy` | Bitnami | From 1.8.0 | 2.1.4 |
| `haproxy` | Red Hat:enterprise_linux:8::appstream | All versions | 0:1.8.15-6.el8_1.1 |
| `haproxy-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:1.8.15-6.el8_1.1 |
| `haproxy-debugsource` | Red Hat:enterprise_linux:8::appstream | All versions | 0:1.8.15-6.el8_1.1 |
| `haproxy` | Red Hat:rhel_e4s:8.0::appstream | All versions | 0:1.8.15-5.el8_0.1 |
| `haproxy-debuginfo` | Red Hat:rhel_e4s:8.0::appstream | All versions | 0:1.8.15-5.el8_0.1 |
| `haproxy-debugsource` | Red Hat:rhel_e4s:8.0::appstream | All versions | 0:1.8.15-5.el8_0.1 |
| `rh-haproxy18-haproxy` | Red Hat:rhel_software_collections:3::el7 | All versions | 0:1.8.17-1.el7.1 |
| `rh-haproxy18-haproxy-debuginfo` | Red Hat:rhel_software_collections:3::el7 | All versions | 0:1.8.17-1.el7.1 |
| `rh-haproxy18-haproxy-syspaths` | Red Hat:rhel_software_collections:3::el7 | All versions | 0:1.8.17-1.el7.1 |
| `haproxy` | SUSE:Linux Enterprise High Availability Extension 15 | All versions | 2.0.10+git0.ac198b92-3.19.1 |
| `haproxy` | SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 2.0.10+git0.ac198b92-8.12.1 |
| `haproxy` | openSUSE:Leap 15.1 | All versions | 2.0.10+git0.ac198b92-lp151.2.9.1 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Fedoraproject Fedora, Haproxy Haproxy, Opensuse Leap, Redhat Openshift Container Platform.

## How do I fix CVE-2020-11100?

Upgrade haproxy to 2.1.4 or later.

## Is CVE-2020-11100 being exploited?

There is no known exploitation of CVE-2020-11100 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11100 and fix it if it is affected.

What it is: CVE-2020-11100 is a high-severity memory corruption vulnerability in Canonical Ubuntu Linux, published on 2 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-11100 in the wild and no public exploit code.

Affected packages and fixed versions:
- haproxy (Bitnami): affected from 1.8.0; fixed in 2.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11100/ (Markdown: https://insights.sbomify.com/CVE-2020-11100/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11100
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11100
- OSV: https://osv.dev/vulnerability/CVE-2020-11100

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11100/
Summaries are generated and may contain mistakes; the official description above is the record.
