# CVE-2020-11110: Grafana stored XSS

> Attackers can inject JavaScript into Grafana snapshots via the originalUrl field, leading to stored XSS execution when users view the snapshot.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-grafana-2020-11110, GHSA-xr3x-62qw-vc4w, GO-2024-2523, MINI-2g8v-6x8v-3773, MINI-2gvg-x28q-ppm2, MINI-36mv-gpr3-c4cv, MINI-3hmr-mj2f-cc8c, MINI-3jxr-vrf5-vccp, MINI-4hjq-4qrv-hv8r, MINI-4xgm-mwh2-5848, MINI-68p2-fcwc-w3x9, MINI-cw4q-655g-43xv, MINI-f33q-4m75-m8p4, MINI-gmwq-v52m-7m3f, MINI-p79w-ghhr-hq93, MINI-pgq9-hg7r-26m2, MINI-r3w9-q9q9-cm99, MINI-wpfw-wvrg-m2f3, MINI-xfp4-q7q4-f74x, MINI-xjw6-747q-2pq3, SUSE-SU-2020:2715-1, UBUNTU-CVE-2020-11110

## What is CVE-2020-11110?

CVE-2020-11110 is a medium-severity cross-site scripting vulnerability in Grafana Grafana, published on 27 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Grafana through 6.7.1 allows stored XSS due to insufficient input protection in the originalUrl field, which allows an attacker to inject JavaScript code that will be executed after clicking on Open Original Dashboard after visiting the snapshot.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-11110?

4 open source packages ship an affected version, including github.com/grafana/grafana and grafana. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/grafana/grafana` | Go | All versions | None |
| `github.com/grafana/grafana` | Go | All versions | 6.7.2 |
| `github.com/grafana/grafana` | Go | All versions | 6.7.2 |
| `grafana` | Bitnami | All versions | 6.7.2 |
| `grafana` | SUSE:Enterprise Storage 5 | All versions | 4.6.5-3.13.1 |

Products: Grafana Grafana, Netapp E-Series Performance Analyzer.

## How do I fix CVE-2020-11110?

Upgrade github.com/grafana/grafana to 6.7.2 or later.

## Is CVE-2020-11110 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-11110 exists.

Public exploit code:

- Proof of concept for CVE-2020-11110, for educational purpose only (github_poc): https://github.com/AVE-Stoik/CVE-2020-11110-Proof-of-Concept
- Grafana <= 6.7.1 - Cross-Site Scripting (nuclei): http/cves/2020/CVE-2020-11110.yaml

## Other vulnerabilities in Grafana Grafana

- [CVE-2021-43798](https://insights.sbomify.com/CVE-2021-43798/): Grafana Path Traversal (high 7.5, exploited in the wild)
- [CVE-2025-41115](https://insights.sbomify.com/CVE-2025-41115/): Incorrect privilege assignment (critical 10.0)
- [CVE-2022-39328](https://insights.sbomify.com/CVE-2022-39328/): Grafana vulnerable to race condition allowing privilege escalation (critical 9.8)
- [CVE-2022-28660](https://insights.sbomify.com/CVE-2022-28660/): Auth bypass in n/a (critical 9.8)
- [CVE-2022-26148](https://insights.sbomify.com/CVE-2022-26148/): Information disclosure in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-11110 and fix it if it is affected.

What it is: CVE-2020-11110 is a medium-severity cross-site scripting vulnerability in Grafana Grafana, published on 27 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-11110 exists.

Affected packages and fixed versions:
- github.com/grafana/grafana (Go): affected all versions; no fix listed
- github.com/grafana/grafana (Go): affected all versions; fixed in 6.7.2
- github.com/grafana/grafana (Go): affected all versions; fixed in 6.7.2
- grafana (Bitnami): affected all versions; fixed in 6.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-11110/ (Markdown: https://insights.sbomify.com/CVE-2020-11110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-11110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-11110
- OSV: https://osv.dev/vulnerability/CVE-2020-11110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-11110/
Summaries are generated and may contain mistakes; the official description above is the record.
